Server License Expired error

i have downloaded community version however after installation when i click on “Get Free License” i get the error message server License expired.

Apparently if you are using the community edition, you have to renew every 2 months using this link:




The Community edition needs a refresh every 2 months. This means that you have to send us your device ID,using the below link and we will refresh the license for you.

You can use the link shared by @Karol

Happy Designing :slight_smile: Cheers!


1 Like


Is this still applicable to the new version of UiPath CE 2017?



I have the same activation problem, when opening application does not indicate that I have to validate and when I execute it gives me the error: You are not licensed to run UiPath activities.


I still have the problem with “server license expired” afther using the link shared above -



Any update? I am getting the same error. Is the refresh on the license supposed to be automatic or it will take some time?


Hi Vikas,

I have done this in going to the link share by Karol submitted the form restarted my whole system.
still my uipath now working.
again getting the same message renew , activate and all.
Plaese help me as i have to give one presentation very soon.

1 Like

I have the same issue…
Activation failed with error: 0
Error description: No Error
License status: Server License Expired

Device ID: xxxx
Computer: xxxx
User Name: itdcsd

Yeah, same issue. “Server licence expired”- have reset it almost 10 times now, un/re installed uipath, restarted my machine, check all email folders but can’t get into uiPath still. Please help! are we just locked out of community edition now?


I have the exact same issue!

Ok guys, for me it turned out that the device ID that was auto filling the device ID field on the renew licence form (online) was different to the one in the Uipath popup window. I just copied the device ID from uiPath and replaced the auto generated one in the renew form. Hope this helps

1 Like

Has this been solved? I’ve tried renewing through the link with no success. I am reasonably sure I never installed a Trial version yet. I’ve downloaded the latest version again (2018.1.3) and am still getting the same error.
Any help?


Hi Stratum,

The link to renew is working fine now. Did you have UiPath Studio with free license(Start free), then it expired and now you cannot renew using that link? Can you please confirm this?

Correct. I also tried reinstalling the latest version as well as renewing the link through the link. I also tried executing directly uistudio.exe to make sure it’s not going to the installer again. No luck.
Any ideas?


Hey all,
so, for no other reason than stubbornness I tried again, uninstall; clean registry; get latest version; reinstall; enter email; get error; go to renew page; enter info; launch UIPath. And it worked. Didn’t do anything different, problem cropped up but was now fixed with the renew page suggestion. I’ve checked the logs and all I found was that it couldn’t find UIPath.Settings file (which was where it’s supposed to be) and after the whole shebang, that error went away. Why? Beats me.

Sitrep done, so long and thanks for all the fish

Tried & Tested (T&T)

close everything (Activation Error pop up, all open windows, tabs, browsers ui path studio etc etc)
delete ui path license folder from “C:\Users\Andy Rockford\AppData\Local\UiPath”
use ui path renew community license link “”
enter all your information followed by device id (Whenever your try to renew Ui Path Studio, in window device id pops up copy that ), device id looks like this “WO+qHurN6qO5A9u7vDha”, and submit it
you will get this message "Unleash the Robots!
Thank you for submitting the form. Your license has been updated, please restart UiPath Studio Community. "
Start your Ui Path studio, pop up will get open enter your email id device id (if asked). you will get below message “Thank you! UiPath was successfully activated on your computer”
if above worked for you then then forget to like the post. comments are welcome :slight_smile:

Thank You !!!
Gaurav Kale


This works. Thank you Gaurav Kale,

Hai Gaurav,

I tried this for many times, as you said deleted the license folder and all in the local of my system. But unable to open the studio getting the below error. And also renewed the license by submitting the form.

“Activation failed with error: 0
Error description: No Error
License status: Server License Expired”

Can you please tell me how to solve the above issue.