Send SMTP Mail Timed Out While Waiting For Mail Service To Connect From VM


I’m using Send SMPT Mail Message activity to send the email notifications for my robot. We can only access the robot email account through outlook web or SMTP options, as the license type for the email account that we created for automation is E1.

We are able to send emails through Send SMTP Mail Message activity without any issues in our local laptop. But when we run the job within the VM we are not getting any response when the robot reaches the SMTP mail activity step.

I referred similar SMTP issue topics in UiPath Forum and changed the package version to V1.10.5. Also tried with the latest versions of the SMTP mail package, but no luck.

When ever we encounter this issue the robot stuck in this step for a long time without throwing any error. The temporary work around that we found is to restart the VM and trigger the job again, but that also not working sometimes.

Anybody faced the same issue or any suggestions for this issue?


HI @shajanjose

You can try to update the Mail package.

Increase the TimeoutMS

They are blocking the service for 3th party users eventually. Restart a VM.

We needed to add ImapX as a dependency to the package

Refer to the Documentation


Hi @Gokul001

Thanks for your response.

Tried to update the SMTP package into different version from old to the latest one.

Also increased the TimeoutMS property, but no luck. Documentation link that you shared is the definition of SMTP activity properties. I’m familiar with this activity and used in my previous organizations network.

This is the first time I’m facing this time out connectivity issue. I also suspect that the service for 3rd party users are blocking. But my question here is if the 3rd part service blocking on VM then how its working if I restart the VM?

Restarting the VM is temporary solution for this issue, because every day we are encountering this connectivity issue and restarting the VM to trigger the jobs.


Hi, Try closing the Ui Path Assistant from the system tray icon and clear the temp files from the appdata folder. It worked for me.


Thank you. This was the solution in my case.

1 Like

How to add ImapX dependency to the package ?