Send Outlook Mail Message : Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))

activities
#1

Hi I’m getting below error while sending the mail.

Send Outlook Mail Message : Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))

Please help me in resolving this.

Error 80040154 UIPath when using Send Outlook mail message activity
Level 1 - Foundation Training - revamped - Lesson 11 - Practice 2 - Send Outlook Mail Message : Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))
#2

Hi @DAishwarya

I moved your topic to our Bug reports category. Could you provide more information according to the template which you can find over here:

The version of the software and the Email activity package are most important here.

#3

Hello,

Scenario:
Trying to use Microsoft outlook activities( Get and Send).
Current Behavior:
While sending the outlook mail, thrown below error:
Send Outlook Mail Message : Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))

Studio Version : 2018.1.2 Community Edition
Mail Package Version : 1.2.6863.29868

Please suggest any changes or information from my side.

#4

Which version of Outlook is it? Also, is it open and logged-in to your account while you are trying to run the process?

#5

Outlook version : 2010
Every time when I run the process, I need to give login credentials.

#6

Basically, when I open/ launch Outlook… It will ask for credentials even if I check remember credentials.

#7

Hello, Any Update?

#8

Hi DAishwarya,
This shouldn`t be an issue if the credentials are configured correctly in Outlook.

I`ll suggest two things to do and see if they work:

  1. Update the mail activity package to the latest version (if you`re not using that already). The reason is that the latest version contains quite alot of fixed for various bugs.
  2. Try to make sure that the Outlook Users are configured well.
    A hint for me that thats the source of your troubles is the fact that Outlook keeps asking for your credentials when its open.
    Theres a way to check in Windows how your users are configured, which is to go to : Start -> Type Credential Manager -> choose the Windows Credentials Tab, and look under credentials maked as : "MicrosoftOffice", or the something like your own Mail Server address. something like mail.myownserver.net. There, youll have a username and password for the users that Outlook uses to log on to our mailserver, and if these arent correct, or the right user is associated with an incorrect password, then it wont work.

Please try this and let me know what you find.

Below is the Microsoft article which has some more info on the matter. I hope this helps!

https://support.microsoft.com/en-ca/help/2762344/outlook-continues-to-prompt-for-credentials-after-your-domain-password

Level 1 - Foundation Training - revamped - Lesson 11 - Practice 2 - Send Outlook Mail Message : Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))
#9

I am also facing the same issue.

image

1 Like
#10

Hi @5a3kh4n

I found out that for this particular error, you need to to start Outlook by using “Open Application” or “Start Process” activity in some environments before calling “Send Outlook Mail Message” activity.

Let us know if it worked for you :slight_smile:

1 Like
#11

Thanks Maciej,

Let me check it out.

1 Like
#12

I tried with Open application but still getting the same error. Kindly.

#13

Hi @5a3kh4n

What is your version of Outlook app and of the Mail activity package in Studio?