Send hot key (ctrl+v) in web automation executing but not pasting

Hi,

I working on web automation in community edition

In which I am using send hot key(ctrl+v) to the browser,it is working fine when the screen is unlocked-(pasting successfully in the browser)

But when the screen is locked- send hot key is executing successfully but it is not not pasting anything in the browser

Note -I have tried adding delays but no use and tried with type into activity too but it is not typing in both(locked and unlocked condition)

Could you please suggest any solution

Hi @Saravanan_Murugan
Can you tell your exact task?

hello @Saravanan_Murugan

The Activities like HotKeys and Normal Clicks and Type into (neither simulate nor send windows message) wont work when screen is lock.
You will have to use simulate click or simulate type into etc in your automation to get the work done.

Yes,

Actually I am into a project where we need process(get the key 1) the random key from the browser

And then process it via key generator(get key 2)

And then paste in the browser solution tab

For pasting in the browser I am using send hot key-ctrl+v

( I have pasted the key 2 in note pad-which was generated by key generator and copied the same with send hot key (ctrl+a) and (ctrl+c))

All these things working well in the screen unlocked condition(pasted key 2 )

But in locked condition it is executing successfully but not pasting the same in browser solution tab

Instead of pasting
just create a variable and store the key 2 and give the Type into into in Browser
Have you tried this?

Hi,

Thanks for your reply @AkshaySandhu @Sudharsan_AIT

Yes I tried that too

Used type into activity with simulate type

Checked click before typing and empty field too,

But none of them working even in the unlocked condition - not giving any errors as well as not typing in the browser

have you tried send windows message option…?
update: you can try set text activity as well

1 Like

Yes I have tried windows message

Actually in simulate click I have seen the cursor blinking in the field but not typing anything

If I use windows message it is straight away moving to the next activity without throwing any errors

can you check Set text activity…?

Yes but set text activity can be combined with send hot keys right

I have done that and got error while executing when the screen is locked(set text activity contains one or more error in uipath)

Try change it in properties “double Click” and try set Text activity too as @AkshaySandhu suggested

if possible you can upload your xaml here…?

Yes I can do that,but web application is password protected

That why’s I cannot able to do the same

And @Sudharsan_AIT ,yes I have tried to add click activity before type into activity(with double click),but I can able to see the cursor blinking in the field but not typing anything

Have you checked manually once to copy the key ?

Yes i have tried copying it manually and it is working fine

but only issue is while typing the same in browser or sending the hot keys(in both i have used simulate click and send windows message) but only the cursor is blinking and not typing anything

i am surprised why type into activity is not working even in debug mode(not throwing any error as well as not typing anything with blinking cursor)

please upload your xaml. It is fine if we are not able to access the application.
Just make sure xaml file does not contains any confidential info.

Hi,

I have created a sample XAML file ,with empty URL but the activities remains the same

Main.xaml (10.6 KB)

1 Like

Main.xaml (10.3 KB)
give this file a try.
If does not work then try with AlterIfDisabled = true in property pane for set text activity

1 Like

Hi,

thanks again for your support @Sudharsan_AIT @AkshaySandhu

I have tried the file and also(Alertif disabled = true)

But same thing happening, cursor is blinking but not typing anything


Apart from this field whether all the others is being clicked by the robot (i.e, Bold,italic)