Selectors Error on Excel and Internet


I am seeing a consistent issue when I build out a process. When I want to simulate a click on an webpage sometimes the bot will do it sometimes it won’t. For example, if I test it once it will click where I want it to click and if I run it again it will not find it. The selectors all of a sudden becomes invalid.

This also happens when I am trying to click “File” and “Save As”. This is a process when I am trying to download a file from a website. I have tried only clicking the aaname or taking out the generic selectors.

Does any one have an idea of why this is happening? I have attached pictures for references.

Please share your Main XAML file

ServiceNow Download-copy.xaml (26.7 KB)

Good Evening @MartianxSpace,

Please see the attached xaml file. Any information you can send me, would be greatly appreciated.
Thank you again.

@Sugaray That XAML file contains missing activities. what happens when you repair the Selectors?

I made a copy of the XAML file since it holds passwords and usernames and had to delete it from file. However I didn’t delete it any activities.

When I repair the selectors it will work for 3-4 activities than the following activity’s selector becomes invalid. Or if it runs all the way through and I try running it again, it gives me errors of selectors being invalid or it can’t find it on the screen of where to click.

@Sugaray Try to run it on debug mode and check which selector is throwing the error

I’ll try to do that tomorrow. Unfortunately my job is working on the server and I can’t log into the websites for now.

If that doesn’t work, what else could it be? It’s just weird that for one test run it will work but for the next test run it will error out.

Seems to be selector issue and can be fixed easily by UiExplorer

@Sugaray - Please use Uiexplorer to create the selector. Use wildcard as well if it will not work then use Anchor options to create a stable selector.

Hope it helps.