Selecting and Freezing a different selection

For eg:

I’m trying to select Model here… and when I do, after some time the selection automatically goes down to qreqt1 somehow and even the green Target Selection is moved down. When I go to setting I see that Model is selected… and when I RUN the sequence… the qreqt1 selection is used.

What is wrong here?

To actually select Model… I have to click on the - sign to the left of Model to collapse the tree into model… thats the only way I can select model…

Please fix this.

can you try click Model and set click offset (X) to something like -10? This way it will click the - sign. If its not clicking you can adjust the offset

or you can click the - sign (capture image) and use “Model” button as anchor

my main goal is not about clicking the - sign… its selecting model correctly

Btw where did you get this menu about offset and other options?

Hi @KD11 ,

Could you toggle over to Hardware Event and see if that works out for you?
Hardware Event is present in the Modern Click Activity, if you are not using that and using the Classic Click Activity instead, then uncheck Simulate Click and try once more.

If it doesn’t work, could you please share a snapshot of the Selector and of the highlighted element with us?

Kind Regards,
Ashwin A.K

Hi @KD11

Is this an issue with the UIAutomation or does the same happen when you work with that tool manually?

Or is the issue that after some time spent manually in your app the selectors of your Click activity become outdated and it starts pointing to another element when automation is run?

yes… only this, I’ll have to struggle to select Model… but If i go back again… its selecting something else… below MODEL

Could you maybe share the two selectors?

One for:

And one for:

Also, what is the version of your UIAutomation package?

dont know what u mean by this? Like you want screenshots?

I’ve installed everything in the past 2 days… so it all latest stuff

@KD11 select Model and give us a screenshot with the state similar to this:

I’m using CV Click so I’m seeing it differently

hi @KD11, as @loginerror was also asking earlier: Is this an issue with the UIAutomation or does the same happen when you work with that tool manually? We might need to setup a call to look into this, as we need access to the application itself (doesn’t look like an issue related to CV not being able to detect UI elements on the screen).

cc @sbotan

it happens only with UI automation

In that case, I’m sure @Bogdan_Sultana and @sbotan will be happy to schedule a call with you to dig deeper into the issue, if you’d like us to have a look. Please let us know :slight_smile:

1 Like

I have found a work around for that I’d say…

If you wanna schedule and call and fix help me with something… I’d vote for this Check App state issue… I’ve tried it with notepad and it works… it waits nicely for my desired element to appear and takes action…

But with the software i’m trying to automate… its been a total nightmare… I’ve tried every setting there is(maybe I missed something?)

Any way thats what I need help with. Talked to many “experts” and “masters” and “advanced users” of RPA here but no one has been able to help

Sure. I’ll switch to a private message so that we can find the suitable time for everyone.