SEEBURGER BIS6 (Zulu JAVA JVM)

When using the selector do get fields of the JVM, I always got notifaction to install the Java Bridge. But even after manual copy of jar and dll, as well as adding "-Djavax.accessibility.assistive_technologies=UiPath.UiPathBridge " did not changed anything.

Hi @TP2B,
Welcome to the Community!

Hope that this will help:

What I did:
installed by Studio Startpage (Backstage)
installed by UI Explorer (after asking, ending the Java app)
copied the files manually
added the command line manually
All installations didn’t changes anything. But putting the accessibility.properties file in the /config folder of the app, terminated the app directly after start with errorlevel=1.

The standard command line was:
-Xms64m -Xmx512m -XX:+UseG1GC -Djavax.net.ssl.trustStore=“lib/trustedcerts” -Dserverbase=“h_ttp://localhost:10000” -Dsun.java2d.d3d=“false” -Dapp-context="/seeburger" -Dnlslanguages=“de,en” -Dcom.seeburger.logger.strategy=“console” -Dcom.seeburger.guicore.modules.Node=“frontend” -Dcom.seeburger.guicore.login.Title=“Login - BIS6 Front-end” -Djavax.wsdl.factory.WSDLFactory=“com.seeburger.pd.io.wsdl.impl.WSDLFactory” -Dcom.seeburger.guicore.ApplicationName=“BIS6 Front-end” -Dcom.seeburger.guicore.SplashScreenImage=“com/seeburger/resourcepool/bisgui/images/splash.gif” -Dcodebase=“h_ttp://localhost:10000/seeburger/app” -Djavax.xml.parsers.DocumentBuilderFactory=“com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl” -Dcom.seeburger.guicore.HelpSet=“bisgui” -Dhomepage=“h_ttp://localhost:10000” -jar “%FRONTEND_HOME%lib\com.seeburger.gui-framework.frontend-bridge.jar”
(I underscored the http->h_ttp due to post limitations)

Hi @TP2B,

  1. What version of Java are you using?
    If it’s 8 or lower, then -Djavax.accessibility.assistive_technologies=UiPath.UiPathBridge is ok, but if it’s higher, you will need something like -Djavax.accessibility.assistive_technologies=UiPathJavaServiceProvider

  2. Is there any error message logged with the errorlevel=1 error?
    Adding the above flag with assistive_technologies in the command line and pasting the accessibility.properties files will have the same effect. The best method, if possible, is the first one, with specifying this via command line parameters.

  3. What is the full command line with the uipath flags?

Also, If you want, we can talk via a zoom call and the process could be a lot faster.

2 Likes

Everyone who wants to try. Download the jide_demo from here:
http://www.jidesoft.com/products/download.htm
Start, install the UIP-Java Bridge, restart and nothing changes (Still no element accessible).
Java console says:
UiPathBridgeImpl call start native
Exception in thread “UiPathBridgeThread” java.lang.NoClassDefFoundError: UiPathV8/MatchingResult

Hi Tobias,

Since we took it offline and solved it, can you close this topic :smiley: ?

For anyone interested, the solution was reached by following the steps presented here: Extension for Java. One single problem in that example command : C:\Program Files (x86)\Java\jre1.9.0_xx \bin\java.exe -cp SwingSet2.jar; C:\UiPathJavaExt\* -Djavax.accessibility.assistive_technologies=UiPathJavaServiceProvider SwingSet2 . It should have no space between paths enumerated in the -cp parameter: C:\Program Files (x86)\Java\jre1.9.0_xx \bin\java.exe -cp SwingSet2.jar;C:\UiPathJavaExt\* -Djavax.accessibility.assistive_technologies=UiPathJavaServiceProvider SwingSet2

Also, since the example may not be so relevant, the last word in the above command represents the name of the main class of the .jar file, as it appears in the manifest file.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.