Screen Scraping Enquiry

The following are the instructions of an exercise regarding screen scrapping in the RPA Nanodegree courses;

Use Open Browser activity and enter URL `Google Images
1 * Use Type Into activity in Open Browser activity and search “text images” in the URL.
2 * Use Screen Scraping from Design ribbon to select an image containing text.
3 * Choose Tesseract OCR as a Screen Scraping method. Change Scale as per the image text.
4 * Use Write Text File activity to store content in a Notepad file.

I am done with the first 3 points and got stuck with the “4th” last point, as after I added the activity of the Write text file and put the path filename of the notepad which to be filled with the scrapped text; the error is appearing from the Text; Can anyone support me with this enquiry to be able to complete my workflow

I would be thankful for this support.

Definitely! Can you please share the error screenshot?

Can you please specify the error. Will be helpful if you could share image used for OCR, the code and the text file you are finally saving text to?

@SantoshPothina
@Jamal_Malik

This error is appearing in the write text file upon filling the part of the destination notepad file.
I am stuck with the Text field ; it’s making an error upon trying to write the created variable of the scraped text !! That’s all in brief regarding the point

image

@SantoshPothina
@Jamal_Malik

@Mohamed_Hassan - scrapped text should be the string type…ans this should be the output from previous activity.

Please check your get text activity output variable and properties.

Yes, I know that it should be the string type to be shown in this

I added the variable of “scappedtext” in string type but making the same error !!

there is something mismatching in properties i think so

@Mohamed_Hassan - Please share the screenshot of the Get text and tessaract properties.

@prasath17 I think the error is in the type but we I solve it from a side the other part makes another error :confused:

@Mohamed_Hassan - ScrappedText should be given in the “Text” not Result…Please see the description of the text when you hover your mouse…

image

2 Likes

Yeah, it worked and ran the work flow successfully

Thanks a lot, Guru

1 Like