Screen not found successfully error message

Hi,

I need help, I was trying to run a process that is supposed to automate logging in a website and then finding the page right after logging in. Somehow the process shows that page but says in UiPath “Screen not found successfully.” I haven’t found a solved similar issue in UiPath, but if there is one, I’d like to see it. I’m using Studio 2021.10.5. Below are the packages I’m using, if it helps.

image

UiPath.UiAutomation.Activities: v21.11.0-preview

UiPath.System.Activities v21.10.2

UiPath.Excel.Activities v2.11.3

UiPath.Testing.Activities v1.4.2

The screenshot didn’t seem to appear here…

Hi @MilTri Welcome to the Forum :slight_smile:

Was working fine previosly? you can always use the IU Explorer to adjust your selector.

Let me know if that helps.

Hi @MilTri

In what way you run the process ? Debug or Run mode

If you run the process in Debug mode it will show this error. Can you try to run the process in Run Mode

Can you share the Selector from the UiExplorer

Regards
Gokul

I’ll try that.

Right, I simply pressed on the run icon. I’m not at my computer now but the selector was something like “…dashboard…” I’ll need to get you the specific selector.

Okay @MilTri , Once your available share the selector. If possible share the XAML file

Regards
Gokul

@MilTri Did you try with Element Exists instead of CV Element Exists. Also, check the boolscreenfound variable assign as a output to CV element exists activity

Tried using UI selector…I did notice UIPath managed to probably mouse over one of the buttons on the screen it was supposed to find, but produced the same “screen not found error.”


This is what I got when I tried Run mode. The selector is:

(The text that says “Dashboard.”)

Process.xaml (15.8 KB)
ACME_Login.xaml (68.1 KB)

It seems I don’t have Element Exists, only CV Element Exists. I’ve checked the boolscreenfound variable, but what are we checking for exactly?

For those of you who don’t have it, this is what I’ve encountered when trying out the proposed solutions:

And the template where this error is…
Component_Template.xaml (20.1 KB)

Hi,

In this version of UiPath Studio you will not find Element Exists activity. Search for ‘Check App state’ activity. this will give you a Boolean value as a output depending upon the particular element presents or not.

Hope this helps.
Thanks!

Hi @MilTri

You need Select the Show classic option in the Uipath

image

Alternative

Go to Project → Setting → Modern Design Experience (Disable)

Regards
Gokul

3 Likes

@MilTri The error says that variable is not declared. It could happen because of not properly defining scope of the variable

  • First click on the element exists in the cv screen scope
  • Expand the variables panel
  • Click on the drop down scope of that variable

  • Now choose the scope as ACME_Navigateto… or ComponentTemplate(based on ur screenshot)

Now run the process and let me know if it helps

I’ll try that out.

Say, I tried switching UiPath to its classic design (not its modern one), then I was able to access element exists, and then fix the scope of boolScreenNotExists to the sequence it was part of, and it worked! UiPath found the screen it needed to find. Thank you all, I appreciate the help! :slightly_smiling_face: :smiley:

I tried all these things that I said I tried in my last post, it seems I can only pick one of the posts as the solution, but it seems getting UiPath to not show its modern design experience helped to get element exists.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.