Schedule orchestrator

please help me I want the robot to start every minute the status of “NEXT RUN TIME” it changes sometimes "a minute " and sometimes “a few seconds ago” but nothing starts :disappointed_relieved:I am sorry for my bad English

Hello @Hind_Haline,

Kindly check the following:

  • The “Jobs” section of the Monitoring Tab and see if there are any pending jobs there.
  • Your Robot types.

This issue you’re experiencing could be caused by incompatible robot types.
I can see that you’ve chosen the option “Allocate dynamically” for the robot, but please be reminded that only Unattended bots can execute processes via Orchestrator.
If your robots are let’s stay type studio, or attended, then Orchestrator will not be able to allocate this scheduled job to these robots, but the trigger will still run.

Try checking the above mentioned points out and tell me how it goes.

Happy automating, Stay safe & healthy! :vulcan_salute:

I only want to display a message “Hello world” but it doesn’t work

when i click on specific robots i can’t find my robot

Hello @Hind_Haline, hope you’ve been doing well.

Again, the most likely reason why your triggers aren’t working is because there aren’t any robots available to execute it.

Now, you mentioned that selecting the option “specific robots” doesn’t show your robot. Please check the following:

  • Make sure that your robot is of type “Unattended”.or “Testing”
    • You can check this via the “Management” Tab > Robots
  • Make sure that the robot and the process which you plan to create a trigger with both have the same environment.
    • You can check the environment of the Process via “Automations” Tab > Processes. Check the column name “Environment”
    • You can check the environment of the robot you plan to use via “Management” Tab > Robots.

Now, in case that the robot & process aren’t in the same environment you can do any of the following:

  • Delete the current process in your Orchestrator then readd it and place it in the same environment as the robot, as you can only set the environment of a process during creation.

OR

  • Add your robot to the same environment as the process.
    • You can do this via the “Management” Tab > Robots > Environments. Select the environment where the process has been allocated and go to Manage and click on the check box with your robot’s name to add it.

Hope this solves your issue. In case you’d need more assistance feel free to reply back .

Have a fantastic day, stay safe & healthy! :vulcan_salute:

2 Likes

@Hind_Haline -

  • how many robots available in orchestrator?
    ---- if its only one robot available in orchestrator -> pls choose specific robots and select the robot from the list. it will trigger every minute.

dynamically allocation of robot -> job will move to a queue and which ever robot is available will allocate. this will be good option when you have multiple robots available and execute the job as when robot available.

Thanks @BenMar,

Had the same scenario and your info helped me managed it, Be Safe!

1 Like