Process not ran by orchestrator

Hi,
I have scheduled 6 processes on one robot and I set the time for all with a difference of 2 min.
A at 12:10 am
B at 12:12 am
C at 12:14 am
D at 12:16 am
E at 12:18 am
F at 12:20 am

Today my only processes A and B ran but not the rest of the 4 processes. Please suggest what can be the issue.
Even there is no error message how I know what could be the issue, why the rest of the process does not run? @Palaniyappan

1 Like

Did we check the log or in jobs tab where those remaining process got trigger atleast
Cheers @balkishan

1 Like

No, they didn’t not triggered bro so there are no logs for those. Only the logs those triggered A and B.

Then we need to check with schedule itself once
Where they are mention correctly and is enabled
Cheers @balkishan

1 Like

All are enabled bro and showing the correct time

Where they scheduled to run with the correct robot
Cheers @balkishan

1 Like

Yes bro. I have assigned all process to the same robo only. since I have only one robot. but only the A and B process got triggered not C, D, E and F. All are enabled.
FYI
image

1 Like

That should work actually
I wonder why it didn’t
Kindly delete all of them and recreate them
Once and check
@balkishan

1 Like

but I am wondering why these are not got triggered if 1st & 2nd got triggered.
If everything is fine.

1 Like

Were we able to run them
Or run them manually that is trigger the job from JOBS tab and pass different login parameters each time and let’s check if that is working first fine or not

Cheers @balkishan

1 Like

I ran manually those not triggered. And they ran fine.

But que is if today they will not trigger automatically. There are no logs for those not triggered. All looks fine in the trigger tab.

1 Like

@balkishan
Why have you told each process to stop immediately? The Stop After time is 0 seconds for each process, which may cause issues with Orchestrator since it’s trying to start and then immediately stop each job.

3 Likes

Yah I didn’t see that :expressionless:
@DanielMitchell He is correct buddy
Do we have any reason to do so @balkishan

1 Like

Hi Palani I didn’t specify that stop after 0 second. It’s automatically come. I just the time gap of each process 2 min. so they start one after other.
Please suggest what can I do now? I don’t see in the edit setting where I can increase the time.
@DanielMitchell

@balkishan
Can you edit each schedule and try setting the “Stop Job after” slider to off.

I’m running Enterprise 2018.4.2 so I don’t know if Community edition looks different but you should be able to set a schedule up without telling Orchestrator to stop the job at all. You can see below most of my processes allow the bots to stop on their own.

1 Like

So I have to edit the Stop Job After ?

Can you please explain me what does it means by Stop Job After ?

I am using the enterprise edition only @DanielMitchell @Palaniyappan

1 Like

@balkishan
It means that Orchestrator attempts to stop the job after the set amount of time goes by. So if you set it to 1 hour then once the bot has run for 1 hour Orchestrator will send it either the ‘Kill’ or ‘Stop’ command depending on which option you select.

I believe it defaults to ‘Kill’ which in your case with the 0 second stop after it means that Orchestrator is sending a ‘Start’ immediately followed by a ‘Kill’.

1 Like

Thanks for the info.
**Okay If I set same setting for all my six process. **
Does it means if A process finished then after 1 hour the second process will start?
or Is the meaning of once A start it will stop by orchestrator after 1 hour whether it’s run complete or not???

image
Is the setting okay ?

FYI
image

@Palaniyappan @DanielMitchell

But I wonder like how did the first two bot alone worked then

Cheers @DanielMitchell @balkishan

2 Likes

@Palaniyappan @DanielMitchell

image

Is it the same what I mentioned above ?

As you mentioned in the scheduler is stop after 17 Hour, you know how much you time your process takes, whether it’s complete or not it will stop after 17 hour. Is that right ?? @DanielMitchell