"Save as" in MS Word 2016


#1

Hello,

I have a MS Word document (.doc). I want to transform it in docx document (without using “export” fonction).
I tried differents methods to select the good value (the first in the list) :

  • Use up key,
  • Use Select value (by Label, by idx)

But I can’t succed. Can you help me ?

Kind Regards,
Vincent.


#2
  • Read data from existing word document using Read text within word application scope.
  • Write the data to new document using write text file within word application scope.

Word application scope will automatically create a new file of there is no file in given name.


#3

Hi,

I’d prefer using “save as” function, which conserve all data.

UIPath isn’t able to select a format in “Save as” windows ?
I join my job, if someone can read it and find my mistake. DocToDocx.zip (22.8 KB)

Kind regards,
Vincent.


#4

Are you getting any error?


#5

You can also go to ‘save as’ option using shortcuts. If you are using Office 2013, then it would be Alt, F, A and then B if you want to save it in a new location!

You can send shortcuts using Send Hotkeys activity, preferably within an Attach Window container


#6

Yes and No …

During execution, my bot blocks on the validation of the message about the new format which cans change document (because it doesn’t appear).
This message doesn’t appear because the selected output format isn’t used by MS Word. It save my document in “doc”, and not in docx.

I use MS Word 2016.

Regards,


#7

I use F12 which automatically open “save as”'s window.


#8

Awesome! :heart_eyes: Thanks for the new shortcut :slight_smile:
Does that solve your problem? Is that where you were stuck?


#9

No, I’m stuck because when I want to select the first value of the type of the format, this value seem be selected, but when I press “Save”, it save the document in old format (.doc), not in the new one (.docx).


#10

The script could have run ahead of the application. It happens at times when selecting from dropdowns. Add a delay for a second before you click on Save. You can use the DelayAfter property in the Click or Select Item activity that you have used.


#11

Hello @Vincent,
I downloaded your workflow and I know what do you mean when using the select item it does select it but when clicking save or “Enregistrer” in your case it saves it as the initial .doc format,
it’s like the change is not detected by the save menu,
so you have to work with clicking items much like a human would do,
my question @Vincent is do you have a problem with this method ??
because I have word in english and if I build a process you have to change everything in it because of your french version.


#12

Thanks for your helps.

I added delays before and after, and it doesn’t change anything.

I simplified my bot in a minimal function (openin “save as”'window and change output format - DocToDocx (minimal).zip (22.0 KB)), and I validate manually the form --> my document keep .doc extension.
So, the selection of output type isn’t conserved. I don’t understand…


#13

Tried this workflow of yours. Seems to work fine. Not sure why you are getting to face this issue.
Good that you have figured your work around! :+1:


#14

If somebody have an idea why this bot don’t works for me, I am interested in :thinking:

Regards,
Vincent.


#15

Still not working? The same step?


#16

install ‘word’ package and enclose your activities inside ‘Word application scope’ in an ‘attach window’ instead of using open application and passing arguments there.
image
Application scope will look like this.
image
Not sure if this will be any different for you. But worked for me this way