SAP Save As Dialogue won't respond to UIPath

Hi All,

New here so appreciate any help in advance. I created a bot to run SE16N - run a particular table - and attempt to export it to excel. I get all the way to the ‘Save As’ Dialogue box then no matter what I do it doesn’t respond. I would like to have it enter a file name and select the ‘downloads’ folder from the combo box. When I try to do this - it seems all correct in terms of finding the elements and typing into where needed however when I run it, I get to that dialogue box and nothing happens. Any thoughts?

Thanks!

Hi @ISAC

Welcome to our UiPath Forum! :slight_smile:

Could you use the Send Hotkey activity to do the action instead?

face the same issue, anyone can help to answer or solve?

Hi @ISAC

Have you indicate the save as dialogue box popup in attach window as it is a seperate window and use select drop-down, type into and click activites inside it.

The solution for SAP Export Dialog issue is to activate Modal settings here

Hello Lev
SAP already set as required but still not work.

hi @bingshui-hl

Show me your SAP screen? Show me your Studio selectors?

Best regards, Lev

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

@bingshui-hl @LIM_ENG_KEONG

Please check also this setting. Try it out with Checkbox and without

Does it help?

Best regards, Lev

Hi Lev,
I tried check and uncheck the setting. Both case i get same result. The “Save As” dialog box not response to the code.
If I try to attach windows to the “Save As” dialog box, it is also not working.

@LIM_ENG_KEONG @bingshui-hl

I have created a short video for you

It this the same, what are you doing?

Best regards, Lev

Hello Lev
My process is similar with your video, and I try out with checkbox and without, but the same result as before. The process running before “type into”, no stop and no error message.


image

HI @StefanSchnell

Any ideas, why @bingshui-hl is still getting Windows Popup instead of SAP popup?

Thanks, Lev

@LevKushnir

Hello Lev,
not really.

I tried it with the oldest SAP release from my archive 7.40 PL0 to ensure that this is not a question of the ALV grid release. But it works as in your video.

The TAC SE16N is in my case part of the package WUSL which is part of the component SAP_FIN. In my case it is this:

image

What release of SAP_FIN do you use? What release of SAP_FIN do you use @bingshui-hl?

I remember dark a discussion in the SAP forum a long time ago about the change from Windows dialog boxes to SAP dialog boxes in case of scripting in 2014 with SAP GUI for Windows 7.30 PL8. And as far as I can remember correct the using of SAP dialog boxes is also dependent from the backend version. Maybe you should take a look at it. That would be my only suggestion.

You can find the version in the menu System > Status… and the press the button with the magnifier glas.
image

Let us know your result.

Best regards
Stefan

hello Stefan
Attached is my SAP_FIN.

About the discuss in SAP forum, it’s mentioned by Lev and I have tried out with checkbox and without, neither work.

1 Like

@bingshui-hl

Hello Bingshui,
your component is up to date.

Please try the following steps:

  1. Set your user settings to ALV Grid display
    image
  2. Open TAC SE16
  3. Input table name TFDIR (or any other)
  4. Press F7
  5. Press F8
    Now you should see something like this:
    image
  6. Open in the Customize Local Layout the Script Recording and Playback item
    image
  7. Start the recording by pressing the red bubble.

    Hint: I could be possible that your dialog looks a little bit different.
  8. Open in the toolbar, like in SE16N, the button Spreadsheet…
    image
  9. After select your target format, do you see a native Windows Save as dialog or an SAP dialog?
  10. Don’t forget to deactivate the script recording.

I tried this way on an older SAP system an on a current SAP system, but with the same version of the SAP GUI for Windows and with different themes. The older SAP system opens a native Windows Save as dialog, the newer SAP system opens the scriptable SAP dialog.

So it seems which dialog is opened has something to do with a backend component or configuration.
It seems that has nothing to do with SE16 (or SE16N) itself.
Please let us know your results of the steps above. It is very interesting to know the behavior of your system.

Thanks and best regards
Stefan

Hi Stefan
I’m applying SE16 authorization, then I will give you feedback.

1 Like

Hi Stefan,
I am facing same problem like BingShui. I tried your instruction. I can click on the export button and the save as dialog prompt as normal. How can we proceed?

If I manually run the sequence manually and input the export file name manually, data will be exported to Excel successfully and the UIPath will prompt error as below
image