SAP Access: Type Into Activity Error


We are experiencing a Type Into Activity error while executing our POC project.
Screenshots are attached for your reference.

I’d appreciate if you could give an advice so that we can fix the issue as we are extensively
using “Type Into activity” for SAP login and entering employee claims details into it.


Ajith K

Have you tried using UiExplorer to examine the element? This might help you build a better selector which UiPath is able to work with.

Yes. We have tried UiExplorer to examine the element; but in vain:(

hI @ajithkarat

Try to use this selector in Type into please: <wnd app='saplogon.exe' cls='SAP_FRONTEND_SESSION'/>
<wnd cls='Edit' />

Kind regards,

Hi @ajithkarat,

Can you please check that you have enabled the GUI script in the server side and client side.

You must have to enable the script in both. It is only the possibility to do the automation in UiPath.


Good point @balupad14, but from my experience a popup will show up if scripting is disabled for the GUI. Since it got that far in his script leaves me to believe scripting is enabled already.

I don’t know if the selectors align perfectly with your SAP environment, but here is what we are using successfully.

Attach Window:

Then the TypeInto for Command field:

Maybe it helps, maybe not.

For further troubleshooting, I would suggest using UiExplorer and click on Validate after comparing it with what you are using in your code. I’m sure you already know that though.


Hey, I have created a workflow related to your problem and it’s working perfectly for me.
SAP.xaml (6.4 KB)
Please have a look.

We have tried this method but it doesn’t work.

Thank you. This solution works for typing the transaction code. Still we have one more issue with the type into activity. That is, the values that we read from excel file not copying in to the indicated field even though it selects the indicated field. Please see the attached screenshot below:


Are you using Type into right? Have you tried with Set text?
Moreover you could try to check/uncheck the property Activate of type into

Please try both and let me know

When I tried with set text activity I got following error.


Ok, try again with type into and uncheck this please

I tried this also. Still it is not working.

I tried. But still no change.


I’ve developed few process in SAP and didnt have problems with type into activity…

What could be the problem? mmmm are you sure that field supports strings values? I dont get why thats happening…

Are you able to write other fields? are you getting this problem just in that field/column?

Kind regards,

I don’t know why.

Hi Pablo,

I am developing a process in SAP

and it works fine for a few runs and then it says “Selector cannot be found”
Any idea why it happens?


Hi @Teenu

Probably, that selector is changing at some run.

Have you checked the selector that is failing? I would try that selector in the error case, to ensure that the selector has changed. If the selector has changed, you will have to use some wildcards and adjust a little bit better your selector.

If you give me more info about the selector I will be able to help you deeper.


Hi Pablo,

Issue was Server side scripting value keeps changes to False intermittently and hence unable to identify the elements.

Any guess why it happens?


Just check SimulateType property in Typeinto Activity,that should work in ur case.