Salesforce integration runs into error when there is a special character in a field

I have used Salesforce Integration activiy (UiPath.Salesforce.IntegrationService.Activites 6.1.0) and I have noticed that it runs into error when there is a special character in any of the fields specifically on the Created Lead activity. I originally experienced this in the Lead description field but managed to replicate the issue using the company field. This should be addressed as special characters are common in EU companies.

Screenshot 2024-05-27 131140

Screenshot 2024-05-27 131209

Hello Ave, are u able to encounter this issue in the latest DAP package i.e. under “Available” section of “Activities” tab (LHS of studio 23.10+). Can you please also share what all special characters you are facing this issue? So, that we can confirm on the Vendor behavior also?

Hi @Akshay_Agnihotri, I don’t have an “Available” section in the “Activities” tab, but I do have the “Installed” activities. This one is from the installed activities.
image

And here’s the special characters I tried that causes error:
ä
ĂĄ
ñ
ö

These happen in other services, I reported it in the Salesforce connector last year where it cannot download attachments that have a special character in them.

The DAP ones require Studio 23.10 or higher and UiPath have not done a good job making sure the exisiting ones, for users on 23.4 or lower, are supported.
Just using the DAP ones isnt a good solution.

What is DAP? I’m not familiar with it.

Dynamic Activity Packages (I think).

Basically before each Integration had its own dedicated package, with activities for that connector, they decided to shift that and create a way that they all get done via one generic integration service package.

Problem is that its only available for 23.10 and higher and they seem to have got tunnel vision and seriously neglected support for the legacy ones, instead just telling people to use the DAP ones. I have given some feedback that they cannot do this, the old ones also need support, this is part of that. So DAP isnt a fix, the legacy stuff should be corrected as its still in the support cycle until next year.

1 Like

Hi @Akshay_Agnihotri What exactly is this DAP? Closest hit I can find when searching for packages from Official feed is Microsoft Dynamics CRM and I don’t think it would work with Salesforce.

Edit: I have also found Integration Service Activities which also contains activities similar to Salesforce Activity Package and with the activity from the Salesforce Activity Pack, “Insert Record” does not have the special characters issue, but we recently have an issue where it randomly does not insert some field values and we cannot pinpoint the cause of the error since nothing was changed, hence the switch to the integration service activities.

hi @avejr748 Yes, DAP (Dynamic Activity Pack) has been renamed as Integration Service Package now. I am uploading the below video to showcase the latest Salesforce package.

Also, it is true that 6.1.0 package is in support mode, but even then, any bug fixes would require deployment of new version package above 6.1.0. All packages until 6.1.0 uses old architecture i.e. even small bug fixes would require users to install another package and existing package will not work anyway.

DAP or Integration Service package advantage is that in any future bug fixes/enhancements, users need not install a package as its automatically upgraded and all upgrades are bound to be backward compatible so your existing workflows also shouldn’t get affected. Integration Service package would require upgrade only in the case of major platform changes…otherwise, connector specific features/upgrades are done automatically. I understand that there is some difficulty in moving from 6.1.0 to DAP but, this is going to be just one time as with future upgrades on DAP, users need not upgrade any other connector packages (they will be auto upgraded with latest fixes/features). If you still have any problem in moving to DAP (Integration Service) package, please, let me know the issue…maybe, we would be able to provide a solution in DAP itself.

You still need to keep the old packages up to date though. This is a clear bug in the dedicated Salesforce activity pack and it needs to be fixed, saying its fixed in the DAP is not acceptable.

@Jon_Smith Whenever there is a bug in a Studio version, a new upgrade on Studio is released. In the similar way, when there is a bug in say 6.1.0 package, the only way to fix that bug was to provide 6.2.0 package. Even before DAP, the only way the fixes could have been deployed was via new package versions. This however, will not happen from DAP onwards…because all activities and future upgrades are backwards compatible i.e. they do not require any additional package upgrades cc: @GuyVW @anish.damerla

Hi @Akshay_Agnihotri I have now tried the activity from DAP and indeed it does not have the special characters issue. Lead was successfuly created. One thing I noticed is that using the DAP activity makes Studio sluggish as compared with working with the Salesforce acitivity pack or the Saleforce Integration Service Activity

My feedback is that up until recently, when reporting bugs such as this, as I did with the ServiceNow connector last year, was to refer me to use the DAP packages, the product team recently did the same when I informed of the Open AI connector being wrong.
I also find that its not clearly explained when troubleshooting this way what the differences are.

The same trend occurred above, my feedback is that UiPath need to do a better job of explaining the difference between the legacy activity packs and the DAP ones and ensure that bug fixes on one get to another.
This is clearly not happening if the bug was solved on the DAP but not the legacy ones.

Thank you @Jon_Smith for the feedback. I agree on the difficulties and will discuss the same with the involved teams as well to mitigate this issue as much as possible cc: @gdesouter @leif.lazar

1 Like

Hi @Akshay_Agnihotri I have tried using DAP today and unfortunately the issue exists there as well. Any advice?
Screenshot 2024-07-02 083336

hi @avejr748 ,

Can we please connect over call? It would be faster to have a live debug session…and get to the root cause

@Akshay_Agnihotri Sure… that is also okay but I would say the issue is easy to replicate. Just use a special character on any of the fields in “Create Lead” and the error will come

We have created a ticket i.e. ENGCE-41104 for the above issue and will look into it.

1 Like