Salesforce Connection - Telemetry Namespace

Hi There,

I am using A Salesforce UiPath Activities package, and trying to connect using the Salesforce App Scope.

When I configure the connection and Test, it is successful, however when debugging, am getting this error:

Salesforce Application Scope: Method not found: ‘UiPath.Activities.Contracts.Telemetry.ITelemetryProxy UiPath.Activities.Contracts.IWorkflowRuntime.get_TelemetryProxy()’.

I looked at the Dependencies of the package and installed accordingly, however the 'UiPath.Activities.Contracts.Telemetry still does not exist in my imports.

I do however have TelemetryClient.Contracts, but this is not calling upon this.

Any idea of how to rectify?

Many Thanks!

1 Like

Hey @Kyleb91,

You need to make sure that UiPath Telemetry Activity packages are correctly installed.

If still you are facing issue, Just post the screenshot of the dependencies from the project panel (all expanded)

Thanks :slight_smile:

1 Like

Thanks for the Help @Nithinkrishna

1 Like

Here’s the Salesforce activities dependencies, where they stemmed from also…

1 Like

@Kyleb91, Please delete the telemetry which you have installed separately as it will be auto added under salesforce.

Please make sure you do the same.

image

Thanks

1 Like

Thanks, I see. I have uploaded as per the pic, but still getting the error… :confused:

1 Like

@Kyleb91,

Please try importing the namespace as below.

Type the in the input box as UiPath.Activities.Contracts.Telemetry

Let me know :+1:

Thanks :slight_smile:

1 Like

It does not show :frowning:

This is there though… image

1 Like

Kindly double check once by typing.

If possible share the project, will try what I can do.

Thanks :+1:

Salesforce.zip (652.1 KB)

Thanks a lot @Nithinkrishna I’m not sure what you could do here though… I cannot share the Salesforce scope details unfortunately, but attached is the project files

1 Like

That’s okay. :+1:

Can you able to see the search result, I tried in your project file. Are you not getting the same please?

1 Like

No… :frowning:

It must be my Studio Version?

1 Like

Yep @Kyleb91, Try installing again please

Or could you please try creating a new project and just see this appears by installing salesforce.

1 Like

I am running Enterprise Edition 2019.10.1.

Unfortunately I cannot upgrade as this is the current version the company is using…

1 Like

Okay @Kyleb91.

I can see Salesforce Activity Pack is compatible from 2018.x version of UiPath.

So hopefully that shouldn’t be a problem.

You can able to test SAP connectivity is it ? but failing when you run ?

1 Like

When I Test the Configured Connection it is successful, but then I try to run, and get the original error…

1 Like

Hi , do you still have the issue? I am getting it as well

1 Like

Hey @Bohdan_Levandivskyy1

Still not sure why the Imports aren’t there… I gave up unfortunately and used an alternative Salesforce Activity Package. :confused:

Could you please let me know, what are those alternative?
I raised a ticket to UiPath , will update you as well