RPC server unavailable

Getting error while executing flow. “RPC server unavailable”, How to resolve this error

Can you provide more details on when this error occurs for you?
It doesn’t sound related to UiPath.

For starters you can check:
http://www.dell.com/support/article/fi/fi/fibsdt1/SLN283117

Regards.

Yes i also thinks that it is related with virtual machines and remote machines remote procedure call errors.so please check logs and also tell us error what you are getting?
In what scenario you are working like on remote machines or local systems? Explain little bit more :slight_smile:

Regards…!!

1 Like

This problem occurs because of a mismatch in the computer name and the name that the RPC service expects.

Possible Solution - Cross verify the name of Virtual Machine with the one in UiPath

1 Like

Getting this error while ececuting the Macro Activity. Any solution ?

1 Like

Also receiving error “The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)” when executing the Excel Application Scope activity.

Error only appeared today after creating a new Excel Application Scope in my exiting workflow. Other Excel Application Scope activities in the workflow work fine.

UiPath is installed on a Windows 2012 R2 Amazon AWS EC2 instance.

Unsure why the new Excel Application Scope activity produces this error while the other same activities in the workflow do not.

Hi,

I faced the same issue and I tried putting a delay of 3 seconds between two activities. It worked for me.
You can try it once too. :slight_smile:

3 Likes

This worked for me as well.

Thanks for tip!

Same here ! Solved my problem, thanks for the tip.

Any other way to work around the problem without delaying the flow ?

Regards

@CBahim @pavelhotovec @nesachdeva @BoCoNdOn @rupeshkumar.shah @Vikas.Jain @aksh1yadav @andrzej.kniola @srupesh1906

Hi all, we have been encountering this error today and the delay wasn’t working between scope activities. If you are encountering it when trying to interact with multiple files sequentially, the solution is to add a “close application” activity between each scope. This should eliminate the error - UI Path was struggling to close each file before opening the next and causing some sort of server clash.

3 Likes

Thanks for the workaround @nesachdeva. I discovered that you don’t actually have to delay your workflow, simply adding a delay activity, with the timer set to 00:00:00 works :+1::slightly_smiling_face:

2 Likes

Hi, In our case we were having two excel application scope activities back to back. It fails sometimes very rarely. Since we are using excel scope activity with visibility “False”, there isn’t any application to close using Close application activity. I am trying a fix which would kill the excel application between the scope activities, though a delay might typically help like other users said.

Thanks for sharing your viewpoints. Appreciate it.

2 Likes

Hi @RameshSankarS

Just to add some more context. One of the possible causes of this error is when you output a variable from the Excel Application Scope, then you close your Excel instance (in any way available, by either closing it via activities or killing the process) and then you try to use that variable later on in another Excel Application Scope.
This can be simply avoided by not closing the processes that generated the output variable.

3 Likes

Hi @loginerror,

Am also getting the same issue

Hi nesachdeva,

I have that issue, one question: Where i have to put a delay? between Scope and execute a macro ? Or where ?

Thanks

1 Like

There is an activity called Close Workbook. You’ll have to use this to prevent Excel applications from being locked out. The tricky part is we can see the EXCEL.exe process in task manager (sometime multiples of them) running under the current users account name. These have to be killed explicitly to remedy the lockout situation.

In the Excel Scope activity, you have to return the Excel scope into a Workbook variable. And in the the Close Workbook activity, pass in the work book variable.

image

I have a Robot that opens and closes Excel on a consistent basis and it works without issues.

2 Likes

i am getting a similar issue but for “reply to outlook mail message activity”. in my process i do have outlook activities back to back running and a delay can fix the issue??

did the same & worked. Thanks