Robot execution not getting ended

I am using REFramework and at the end of execution in End State, the UiPath executor closes but the bot does not end and the “Stop” button would still be there in studio. I tried terminate workflow activity but I am getting pop up window which I do not want. Tried throw, rethrow in catch, still getting error message window. Any help would be appreciated. I am using 2020.10.2 enterprise version

This issue can be caused by various factors, but here are some steps you can take to diagnose and potentially resolve the problem:

  1. Check for Hanging Processes:

    Ensure that there are no background processes or applications running that might be preventing the robot from properly terminating. Sometimes, processes can hang due to external dependencies or issues with your automation workflow.

  2. Check for Infinite Loops:

    Verify that your automation workflow doesn’t have any infinite loops or long-running activities that may prevent the robot from reaching the end state. Ensure that all loops and conditions have exit criteria.

  3. Review the Logs:

    Review the Orchestrator logs and the Studio output panel for any error messages or exceptions that might provide insight into why the robot is not terminating properly.

  4. Terminate Workflow Activity:

    You mentioned that you’ve tried using the “Terminate Workflow” activity but encountered a pop-up window. To avoid this pop-up window, you can configure the “Terminate Workflow” activity as follows:

    • Set the “ContinueOnError” property of the “Terminate Workflow” activity to True. This will prevent it from throwing exceptions when it terminates the workflow.
    • Make sure that you are using the “Terminate Workflow” activity in the correct location within your automation workflow, typically at the end of the “End Process” state in the REFramework.

    If you’re still getting an error message window after setting “ContinueOnError” to True, it might be related to another issue in your workflow.

  5. Check for External Dependencies:

    Ensure that there are no external dependencies or activities that are waiting for user input or external triggers that prevent the workflow from ending gracefully.

  6. Update UiPath and Dependencies:

    Consider updating your UiPath Studio and Orchestrator to the latest versions available. Sometimes, issues like this are resolved in newer releases.

  7. Review Error Handling:

    Double-check your error handling mechanisms, especially in the “Process.xaml” file in the REFramework. Ensure that any exceptions are being caught and handled appropriately, and that the process eventually reaches the “End Process” state.

  8. Debugging:

    Use UiPath’s debugging tools to step through your workflow and identify the point at which the execution hangs or fails to terminate. This can help pinpoint the exact issue.

  9. Consult UiPath Support:

    If you’re still facing issues after trying the above steps, it might be beneficial to reach out to UiPath support


Hi @karthiksh ,

Could you maybe provide us with the Screenshot of the Exception Message or the Full Exception Message that you receive ?

Also, Check if the Same happens when you perform Debugging.


welcome to UiPath forum
I believe you are executing the bot in DEBUG mode by just pressing the PLAY button in studio
instead of doing that click on the drop down in that PLAY button and choose RUN PROJECT so that bot runs in normal mode and this wont occur

Cheers @karthiksh

Thanks for suggesting the possible solutions. But nothing worked yet. The bot is processing until the last activity in the End state but not ending execution. Tried putting log message at the bottom, tried in debug. Everything works normally till the end but bot does not stop after execution.

There are no external dependencies or applications opened. The bot is closing all the applications in the end state before reaching the bottom.

I am not able to find the “ContinueOnError” setting for Terminate workflow(may be because I am using 2010.10 version)

I deliberately tried to make exception at the bottom of end state yet the bot still shows “stop” button

I am not getting exception but I tried to create one forcibly so that I could end the bot execution at the end. Results are not fruitful. If you want I can attach the screenshot of Exception message that I tried creating forcefully

I tried in Run mode, debug mode, even in different machine, it’s the same issue

@karthiksh ,

This does look like an Unusual case.
Is it possible for you to replicate this with Other New Created Projects ? If not, Could you maybe create a Copy of Current Project and remove the Confidential information if you have any in it and send the Project here so that we can have a look from our end ?

Also, Mention us the Studio Versions and Dependencies used.