Robot does not start immediately from UIRobot system tray


Is there a known limitation of UIRobot wherein it will not immediately run after I selected the robot in the UIRobot system tray? I timed it and it seems like my robot starts running three minutes after I pressed the process.

※It immediately runs, though, when I “Run” it via UIStudio.
※I tried running the robot in my teammate’s PC and had encountered same delay.

I would like to ask this first in the community before debugging my xaml for possible performance issue.

We would greatly appreciate your response. Thank you!

Hi @marci080

Could you check if it is not project-specific?

Does the same happen if you try to run a simple project with only one Message Box activity?

1 Like

Hi marci080.

There may be a problem with GeneratePublisherEvidence

First of all, do you have the enterprise or community edition ?

Can you please try the steps below ?

  1. Go to install folder
    c:\program files(x86)\uipath\Studio → for enterprise

%localappdata%\uipath\studio\app-18.3.0 → for community edition


3.In the <configuration> tab under <runtime> add <generatePublisherEvidence enabled=“false”/>

The overall structure should be

<generatePublisherEvidence enabled=“false”/>

robot process (close tray from Settings > Quit Tray) → for community edition
UiPathRobot service and try to run the jobs again.


Thank you for the debugging idea @loginerror
I checked with a simple project and I encountered the same problem.
Thus, it is not project-specific. Whew! You saved me there.

Thank you @andreiT for the suggestion.
I have an enterprise edition version 2018.2.3
I tried your solution but the same problem occurred.

However, in the same folder, we edited the ff. config and commented out the myget gallery path. It seems to solve the delay!!!

 <add key="Gallery" value="" />

Maybe our company blocks/checks this external link, not sure though.
When I set my PC to airplane mode, the robot ran immediately (without commenting out the said gallery link). :sweat:

We are not sure if this is the proper way to resolve this issue though.
For now we’ll proceed with this.

Thank you so much!!!


Hi marci080,

Yes, that is a good solution if you are behind a firewall that blocks
What happens is, every time the robot start starts a process, it cycles through the robot feeds from that nuget.config.
If on of them is unreachable, it will retry it several times, hence the delay.

Glad you solved the problem!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.