Response from server is not valid when using proxy

Adding a CV Screen Scope and trying to select something on screen, appear this message


Possibly is not detecting Proxy Configuration (Log):

[ERROR] [UiPath.Studio.exe] [10] Error performing DetectControls2: System.AggregateException: One or more errors occurred. —> System.AggregateException: One or more errors occurred. —> System.Net.Http.HttpRequestException: An error occurred while sending the request. —> System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required.

.config files have proxy configurations and all is working well.


This error comes when you don’t have internet connection and you are trying to run the CV activities.

For CV screen scope, we have a URL mentioned and it’s unable to reach that, so try with internet connect and let me know,

Interesting, we haven’t tested with proxies involved, we’ll look into it.

Can you somehow setup the proxy on a system level, în the network settings?

1 Like

Thanks for the answer, Here it is:

Config Files contains Proxy settings

However CV Image Request seems to be ignoring proxy settings.


What is the server name which we need to provide for server filed in the properties of CV screen scope activity…?

If you add a new CV Scope it will have the field pre-populated with:

But when you indicate some screen in CV Scope, it will throw an error “response from server is not valid” if you mention “” in server property…

1 Like

Could you try again, with the latest version? The server is definitely up, it might be some network configuration issue. If you ping do you get a response?

I’m also having issues with CV screen scope. I was able to get response from and i have working connection as well however still having issues

Are you using a proxy?

I get the same error at work, which uses a proxy. I looked at it with our IT proxy guy, and it wasn’t being blocked by the proxy. He gave me access to our guest WiFi, which doesn’t use the proxy and it worked.
If this can be fixed, that would be great; it’s going to be near impossible to get them to add another rule to the firewall and the guest WiFi isn’t a long term solution either. Thanks

@asesor-rpa your proxy requires authentication? I mean, Do you need to enter Login and Password in order to access Internet Web Sites? :thinking:

I am just telling this, because if your proxy requires authentication you probably needs to request to include the url in the firewall rules to have access.

I had a similar problem here with the proxy authentication. But, first of all i would try all steps following the URL below :


I made all steps to configure Proxy and Robot connects to Orchestrator CE correctly, NuGet packages can download correctly, but What I can see is the activity is ignoring proxy configuration.


1 Like

I used web recorder and it solved my problems.

how do you solve the problem