Reoccuring error load dll 'penimc.dll' after Windows Update


#1

Scenario: After a recent update to Windows 8.1, UiPath didn’t start at all, no error message, the crash log showed an error loading the dll penimc.dll. After some trial and error I was able to reinstall UiPath and start it. But after some hours or minutes of working the attached error message shows up again. It seems to be related to this issue, also we use Windows 8.1 instead of Windows 10 (https://developercommunity.visualstudio.com/content/problem/55303/visual-studio-may-terminate-unexpectedly-when-runn.html)

Steps to reproduce: Start UiPath, Run any workflow

Current Behavior: Crash with attached message

Expected Behavior: No crash

Studio/Robot/Orchestrator Version: 2017.1.6365 (but also with older versions)

Last stable behavior:
Last stable version:
OS Version: Windows 8.1
Others if Relevant: (workflow, logs, .net version, service pack, etc): see attachedstudio.log.zip (24.9 KB)


#2

Hello,

This seems to be a .NET 4.7 issue that is fixed in the Windows updates for the newer Windows version.
This problem is related with the devices that have a touch input device. Is you computer/laptop display a touch one? If yes, there are 2 workarounds:

  1. Revert to .NET 4.6
  2. Add to UiStudio.exe.config and UiRobot.exe.config following:
    <configuration> <runtime> <AppContextSwitchOverrides value="Switch.System.Windows.Input.Stylus.DisableStylusAndTouchSupport=true" /> </runtime> </configuration>

Let me know if any of above worked for you.
Thanks,
Cosmin


#3

Yes, we have a Lenovo T460S with touch display.

  1. I could not revert back to .Net 4.6. because we don’t have an uninstall option. Re-installing .Net 4.7 was also not possible (You have 4.7 already installed…)
  2. I edited the *.exe.config files and that worked. Thanks a lot!

In addition: The error is 100% reproducible by starting UiPath, locking the screen and unlocking it. When closing UiPath and restarting it, it won’t start up until you have logged off from Windows and logged on again. Just FYI
I also tried to disable the touch functionality, but this didn’t help.

Regards Christian


#4

Hi,
Point 2 is a workaround until Windows will fix the problem in .NET 4.7, so do not expect to work flawless.
Reinstalling NET 4.7 is not an option because the problems was introduced by it.
To uninstall try following: to go to Program and Feature, select View installed updates, search and uninstall:
.NET Framework 4.7 for Windows 8.1/Windows Server 2012 R2: KB3186539
.NET Framework 4.7 Language Packs for Windows 8.1/Windows Server 2012 R2: KB3186606

Then try to install 4.6

Good luck