Remove data column not removing anything

Hello, i have some strange problem - remove data column activity doesn’t delete it content. dtb
i’m trying to delete column using only index. And somehow it’s not working. Any advice?

How many columns do you have? Columns are zero based so if you only have 4 columns, column 4 will be 3 (not 4)

Alternatively, could you use the column name instead? This would be a more robust approach.


It’s not working :stuck_out_tongue: strange isn’t it. :slight_smile:
Tried with column name,index and with excel 2007/2010 still nothing is being deleted.
@badita @andrzej.kniola can you guys check and confirm.

There’s more columns, about 15 of it, to be exact. Well, there’s one strange behavior exists:

The data in red rectangle is cleared. But i need the whole column to be deleted. Don’t get how this works at all. Why only this selection cleared? Just because there’s two blank rows below?

Remove data column works within an Excel data table not sheet.
You may use shortcut keys though.


I’m using datatable, deleting column there, and then - exporting whole dtb table to excel.

1 Like

Hey @AlexanderKor

Yes there is something not able to find but you can try the below attached way as well.

Remove_Data_col_from_dt.xaml (7.1 KB)

pass the index of column which you want to delete in below image reference :slight_smile:



Thanks, that worked!