Refresh environment variable without rebooting


#1

Hi

I’m working with uiPath Studio community edition 2018.3
I need to change frequently some environment variables for testing reasons (pointing to one api or another), but they don`t get refreshed on uiPath, unless I reboot mi computer… which is very annoying.

So, the question is: Is this a common behaviour… or could something in my settings be wrong?

I’m using the windows environment variables to change them. If I read them from other programs they appear changed. They just don’t get refreshed in uiPath.

Oh, when I start uiPath I can see some message about NuGet cache not needed to refresh… I don’t know if it’s related to the problem.


#2

Hi.

Have you tried restarting the UiRobotSvc service? I know some settings don’t get refreshed until the service is restarted.


#3

Thanks for answering.
No, I have not. How do I restart that?


#4

There are a few ways to get to it, but you want to go to Services. You can get there from Task Manager or using the Search.

There is also a button that says “Services” for more details on the services.


#5

I could not find UiRobotSvc, but in the “details” tab of Task Manager, I found “UiPath.Service.Host”, and killing it worked for me.

So, in resume what worked for avoid rebooting the PC:

  1. Change env variables
  2. Close UIPath
  3. Open Windows task Manager and kill “UiPath.Service.Host”
  4. Open UiPath
    Thanks!