REFramework: Process finished due to no more transaction data

Hi,

I am trying to read data from an excel sheet and then download data accordingly from a website and then write the data scrapped on the website as well back to the excel sheet. I am trying to convert my workflow into REFramework.

I am having trouble with the Process workflow as it is not working. My GetTransactionData worked well, as I could print the certain columns I wanted to extract from Transaction Data. Please find the screenshot of my GetTransactionData:


However, nothing is working in Process. I have assigned all the arguments as below:

but kept getting the “process finished due to no more transaction data” whenever I tried to do something even just to write the Transaction ID using Write Line. What might have happened here?

Also the workflow arguments for Get Data Transaction

Hi,
Have you checked the values are store in TransactionData after scrapping the Data?

Regards,
Jyotika

Hi yes, I have. I tried to Write Line with io_TransactionData.Rows(io_TransactionNumber)(“ID”).ToString inside Get Transaction Data and it did print the ID of that row out so I assume all have been scrapped correctly?

Hi,
Can you share workflow file here if possible.

Thank you, sorry my workflow contains confidential data. I have managed to figure it out. I didnt assign the out_TransactionItem in Get Transaction Data so it didnt work

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.