Recording doesn't Execute Type Into Input

Today I tried with a colleague the StudioX recording possibility. I doesn’t work as expected. We put into the transaction code (TAC) field of SAP Business Client our TAC with a following enter.

When we press entered of the input dialog we expected that the TAC /nSE16 was written in the input field with an enter keystroke at the end. But nothing happens at recording. When we run that workflow afterwards all works well and expected, but not at recording time.

image

When we use [k(enter)], which we know from Studio, all works well.

What is the correct way to use special keys at recording time of StudioX recorder?

Thanks for hints and tips.

that might be just a bug, it works on a different desktop app.
there is a 20.6 preview release of UiaNext where we`ve fixed a lot of issues in recorder, can you try with that?

1 Like

Hello @Gabriel_Tatu,
thank you very much for your fast reply.
I installed 20.6, but unfortunately it is the same behaviour.

image

So I tried the following with notepad…

…and when I press Confirm nothing happens in the editor.

It seems to be independently from the control.