Read range inside application scope with using filters fails

excel
activities

#1

I have an excel sheet which has filters applied.
Need to get the data on a datatable with headers.
but this operation always fails with error:

Read Range : Out of present range. (Exception from HRESULT: 0x8002000A(DISP_E_OVERFLOW))

Please help.


#2

Hi @akhilesh.s,

Can you please share the file and the workflow?

Regards,
V


#3

I can’t share the file…
Sharing the screenshot


#4

@akhilesh.s, Can you try removing the defined range (“A3”) and check whether it works?

Regards,
V


#5

I have tried with following combination of ranges

  1. balnk
  2. “A3”
  3. “A3:T132” - here the count of data may vary during runtime

none of these have worked.
I’ve created a sample which has same issue.
issue.zip (7.3 KB)


#6

this seems to be a defect, we will investigate further and if its a confirmed issue, it should be fixed in a future release. thanks a lot!


#7

Hi,

I went through the sample and when I remove the fist line or make it empty, it works, you can use this as a workaround till @Gabriel_Tatu confirms further on it.

issue.zip (7.8 KB)

V


#8

Is there already a solution to the filter problem?

For me it doesn’t work either if I fspecify a range :confused:
only if I don’t specify a range it works

But I need the data from one column/ row that is left after using the filter…

Is there a possibility to make this happen?

Thanks!
J


#9

Hi,

I had recently faced this issue, but in my case the problem is with my excel,
My excel has some macro coding in it, where the cell content in one of the column is showing me "#######’ but the actual value of it is different.

You can find the example below :

image

When i made this correct value, I no longer got the error message out of present range.

Hope this help you guys too.

Regards,
Sruthi


#10

wrong range provided in read range, only A3 is not valid please remove all from range and keep it “” empty to read all range specify valid range…


#11

Please extend the length of a column in excel manually…It’s valid and correct value…It will not affect development…


#12

Apply filter then save file and then try to read excel by selecting useFilter property.
It will give you filtered result as output.
Let me know if that solution works.


#13

Is the defect is fixed ?
because I am getting this error ?

is there any way to fix ?


#14

this should be fixed, what excel package do you test with?
can you share the excel file with us?


#15

Due to some reasons I couldn’t able to share the XAML file.

I am using this excel packageversion - 2.0.6526.16321


#16

not the xaml file, the excel file you try with if possible.


#17

I couldn’t able to share that also b’coz it has some confidential data

Is there any way to resolve ?

I couldn’t able to proceed


#18

i need more details so that i can help.

  • you have a simple table, with a filter applied in an xlsx, on sheet1
  • you have read range, no range set inside the excel scope
  • you use Usefilter property in the Read Range activity
  • you run the workflow and getting an exception
    right?


#19

I think I have problem in excel.

I copied all the data into new excel file. I didn’t get any error


#20

oh, ok. yes, sometimes we see issues generated by improper excel files.