Read Range: Failed setting current sheet to

hi, please help me, i’m getting these errors when reading a sheet in excel just recently, before it worked just fine.


image
image

@RobertoEwaldo,

Before run this workflow, check your system task manager for Excel.exe in the details tab. If anything available kill those and check one more time.

This may happen if you are not using Closeworkbook activity after the Excel Application Scope Activity finished.

hi, i already add the kill process activity and close workbook activity, but the error still happens

Dude what @sarathi125 said is please close the excel application then only the bot will run properly i think you not save the excel so its say busy and plz save the excel file before run

Thanks
Chethan P

Restart machine

@RobertoEwaldo ,

Looks like it is a shared path excel file. Someone else might have opened it from a different machine. Try to copy that excel to your local machine and check, if it is working in this case, then the excel might be in use.

hi, tried that a couple of times, still have the same issue

hi, i moved the excel to my local machine and i still get the error, what could be the problem ?
image

nevermind, i tried the workflow in another machine and it worked. I’ll just create another vm then

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.