Excel seems to be busy, failed setting the current sheet to

i encounter this error unexpectedly, there are no problems with the workflow and it has been running fine for weeks even months, but suddenly this happens

this has happened before
i tried killing the process, adding delay, reinstalling uipath, didn’t work. The only thing that worked is i run the workflow in another machine. It’s annoying that this happens unexpectedly, can’t find any solution, and i have to move this workflow to another machine again. Please help, Thanks.


Can you try with another excel?
Use excel app scope and provide name of excel file and try to read it.
if it works so there is no issue of excel.
then prob will be with this file that you’re using.
you can do like this, once excel app scope opens this file, press Alt + Tab keys to see any opened dialog box of excel.

the error doesn’t have any pattern, i use foreach to read every excel in a shared folder and perform some process. It goes like this:
multiple tries:
excel 1 - read successful
excel 2 - error
restart machine, reinstall uipath → try again, same result (error on excel 2)

copy the shared folder to local folder and read from there:
excel 1 - read successful
excel 2 - error

delete excel 2 from local folder:
1st try:
excel 1 - error

2nd try:
excel 1 - read successful
excel 3 - read successful
excel 4 - error

for the record, i copied the workflow to another machine, and now it works fine on that machine

Hi @RobertoEwaldo

I used to see this error

  1. when excel has formulas with functions like Today(), Now(). When such excels are opened and closed there will be a pop up that asks for saving the changes
  2. when office activation message pop up
  3. when there are any links (urls/links to other workbooks) that request for update/refresh before closing

You can check this by manually opening and closing excels that gave the error.

workaround for point 1
open excel → File → Options → Formulas → Calculation options Select Manual and uncheck Recalculate before saving

workaround for point 2
activate your MS Office :smile: or we can handle the pop up message as an exception

workaround for point 3
Check for any connections/links and break them. You can check this under Data tab “Existing Connections”

hope this helped

i have this problem again today, and after i activate my office everything works again, thanks mate :grin: im wonder why activating the office can solve this?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.