I know there is already a thread on naming conventions but I’d like to open one on the RE Framework on this topic. I’m wondering if there is a preferred ‘best practice’ for naming each state and variable in the framework. An obvious approach is to give the variables and states meaningful names according to the project being developed. On the other hand, there may be some advantage in sticking with the default state and variable names, for other developers familiar with the framework. Do UiPath have a guideline on what they consider best practice for this?
the guideline with naming is just to make things quickly understandable by anybody.
Meaningful names are abviously a must do.
You can also use some UpperCamelCase or lowerCamelCase as you prefer, it will ease reading you namings.
As UiPath do in the REF, I like indicating if an argument is in / out or io in the argument naming, I find that helpful in understanding how the values are carried within your automation.
Also, do not hesitate to rename you activities blocks and to annote your sequences.
Thanks Martin. This is what I expected, it seems pretty standard. Just wanted to check if people were using the defaults to make it ‘familiar’ looking between projects.