"Python Scope: The specified Python path is not valid." Error

I am struggling to resolve an error I am getting when I run the Python Scope activity. The error is “Python Scope: The specified Python path is not valid”. I have confirmed that the path string I am entering matches the path listed in my environment variables. It also matches the path shown when I type “where python” in cmd. I am hoping for any guidance.

Hi @Trevor_Alexander ,

Welcome to UiPath Forum :slight_smile:

Please check the python installed file location from your machine.

like above image check in from your machine for python and update the path.

1 Like

Thanks Arivu,

see image below. It looks like the path from cmd matches the path from my first image?

Hi @Trevor_Alexander ,
kindly provide full path and try. if not works try next path.


I tried all three paths with the same result (and adjusted the python version on the properties pane). Still not working. I’m perplexed.

Bumping this in case anyone has thoughts. Does python scope not work for studiox?

Hello @Trevor_Alexander

Please check the below video.


Thank you for sending this video. After watching the video, the way that the he is finding the path and setting the path variable to the path matches the steps I am taking. No resolution yet.

Try the UiPath.Python.Activities[1.6.0] for the Python 3.10

Setup example for Python Scope:

Thanks Marian but I am still getting the error even with your suggestion. See image below which has the error, the path from cmd, and my properties inputs within view. It’s very strange.

Did you try Studio, not StudioX?
Which is your project type (Windows or Windows-Legacy)?
Try in the failed path to add in the end “…Programs\Python\Python310\”

StudioX. I haven’t tried Studio. I’m pretty far along in my project. Would it take a lot of work to convert it to Studio?

Its Windows (not legacy).

I tried adding in the \ at the end with the same result.

I switched to Studio from StudioX. It seems to be “thinking” now instead of immediately throwing an error but its stuck on the Python Scope initialization and won’t move to load script. Any thoughts?

Hi Trevor, did you fix this? I came across this problem and solved it by installing
[.NET Desktop Runtime 5.0.17] as noted in https://docs.uipath.com/activities/docs/python-scope