Python Scope simply not running

Hi guys,

I require the use of Python activities for a work project but I am at my wits end trying to make it work. I have read most of the other posts but nothing has worked so far. I have the following right now:

UiPath 2023.4.1
Python 3.9.13
Python Activities 1.6.0
.NET Runtime 4.8 (as per windows registry, I tried installing 7.0 but it hasn’t shown up)

Do I have the wrong setup? I am quite sure I have used the activity in the workflow correctly. Additionally, the executor stops responding whenever I test the Python scope, UiPath.Python.Host does not run in taskmgr at runtime and there is no error message when I try to run the code. Greatly appreciate if anyone can help me out here


Please check and validate the properties once

Try with a simple python script to start with to know if the setup is proper


Hi Anil, followed this test exactly and it is not executing the scope at all. The execution does not do anything when I press run. Any idea how to resolve this?


Few things do you have only one instance of python?

Is path variable added?

Is it throwing any error?

Did you try with a small py script?

If all of above is good…please share the code you are using or some screenshots to understand


  1. Yes, only one version of Python
  2. Yes, verified by running pip and python straight from CMD
  3. Do you mean the runtime? The runtime does not throw any errors, it just opens and then never finishes. I have to stop the process manually.
  4. Yes, both in UiPath and Python itself

Have attached the file I was working on for your reference. Thank you!

TestWorkflow.xaml (10.8 KB)

Hi all, found a solution in the end.

For anyone who might need this for reference in the future, I uninstalled my .NET runtime v7.0 and installed .NET Desktop Runtime v5.0.17 instead. Restarted my machine after the installation and everything just clicked into place and worked without a hitch. Cheers.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.