Publish of workflow project to Orchestrator failed. Error "Request Entity Too Large"

How to troubleshoot "Publish of workflow project to Orchestrator failed. Request Entity Too Large" error when attempting to publish a project to Orchestrator?

Solution 1: 

If you want to be able to upload files larger than 28.6MB, perform the steps below:

  • On the machine on which Orchestrator is installed, open IIS Manager.
  • In the Connections panel, navigate to the Orchestrator site. The Features View panel is updated accordingly.
![](upload://z4LJQ9lFgVvszDXmR9ge9rhfSYy.png)
  • In Features View, double-click Request Filtering. The Features View panel is updated accordingly.
  • Navigate to the Rules tab. The window is updated accordingly.
![](upload://o6DeQsWsHXpHmfBnAQJ34V4Z0JD.png)
  • In the Actions panel, click Edit Feature Settings. The Edit Request Filtering Settings window is displayed.
  • In the Maximum allowed content length (Bytes) field, type the maximum value that you want to be allowed. We recommend 1073741824, which is exactly 1GB.
        Important: Make sure the Allow double escaping check box is selected, as it enables the correct download of files with space characters
  • Click OK. Your settings are saved.
  • Restart IIS to make sure your new settings are applied.


Solution 2: ( To be followed in case solution 1 fails)

Change below settings in IIS.

  1. Launch “Internet Information Services (IIS) Manager”
  2. Select the site that you are hosting your web application under it.
  3. In the Features section, double click “Configuration Editor”
  4. Under “Section” select: system.webServer  then serverRuntime
  5. Modify the “uploadReadAheadSize” section value 2000000000
  6. Click Apply
  7. Restart IIS