How To Increase The Size Limit Of Project To Be Uploaded In Orchestrator

While trying to publish the project from studio to orchestrator, you might get error "Bad request. The remote server returned an error". How can this be solved?

Step by step guide

  1. The server where Orchestrator is hosted -> Go to Start Menu -> Run -> Type in "Inetmgr" to open the IIS settings.
  2. Expand sites -> Select "UiPath Orchestrator".
  3. Double-click on "Request Filtering" as shown in the screenshot below

4. Select "Rules"

5. Click "Edit Feature Settings"

6. In the dialogue window that opens you can see the "Maximum allowed content length" field. It is set to 30 million bytes by default, which allows you to upload files up to almost 30MB.

Let's say we want our files to be up to 1GB, then we would need to put "1073741824" there (this number equals 1GB exactly)

7. Also make sure that the "Allow double escaping" option is enabled. It must be enabled for correct downloading of files which names contain a space character.

8. Click OK. Restart IIS once. 


If after this steps you still get 413 error please go through the steps:

  1. Launch “Internet Information Services (IIS) Manager”
  2. Select the site(Orchestrator) that you are hosting your web application under it.
  3. In the Features section, double click “Configuration Editor”
  4. Under “Section” select: system.webServer  then serverRuntime
  5. Modify the “uploadReadAheadSize” section value to 2000000000
  6. Click Apply
  7. Restart IIS

 

Reference article in orchestrator documentation can be found by visiting the below link - 
https://orchestrator.uipath.com/docs/increasing-the-size-limit-of-package-files   .