Publish of Process project to Orchestrator failed. The operation has timed out

[ERROR] [UiPath.Studio.exe] [23] Error: Publish of Process project to Orchestrator failed. The operation has timed out.
WARN] [UiPath.Studio.exe] [3] XamlMigration: removed reference System.Runtime.WindowsRuntime

Hi @vzvenkat , Welcome to the forums!

Are you directly publishing from Studio? If yes, would it possible for you to publish the package to your disk and then upload to Orchestrator?

If that works, it would rule out issues with the contents of your package and/or the location where you deploy in the Orchestrator.


Does your project have subfolders? I’ve seen RE Framework based projects where there are so many images in one of the folders that it makes the project too large to publish to Orchestrator.

1 Like

yes i have, i was deleted and tried again still the same error.
Thank you for your prompt response

Sure will try
thank you

Right click your main project folder and go to properties. Tell us the size and how many files.


some members managed bigger automation packages (but did cleaned up in advance) by manually uploading the package to Orchestrator

That’s still quite large. Find out what you have in the folders that’s making it that large.

Try deleting the .settings and project.json
Check of any workflow has annoying character like “%20@”, if yes → remove them
Check if any of the file is having active reference to other location’s file (macro/vlookup in use)

Try opening the main file after all this, project.json will be created again
then try publishing

If still error, try publishing a blank RE Framework process to check if that is working.

We assuming the network connection is not a problem.

DO NOT delete .settings there is important info in there you’ll lose.

What would deleting project.json accomplish?

If we see the error

That indicates there is something wrong with the Windows.Runtime namespace.
This might be due to the fact that the project.json had some namespaces metadata linked to the location of that file originally(may be some other location or system)

if we delete and recreate the project.json, it recreates the required namespaces from scratch as per the schema in Main.xaml, it often helps in side stepping weird errors.

If we delete, the data in .settings, .local and project.json is recreated when we open the Main project file.

Just to mention, In case where the environment is restricted to publish the package from Studio due to governance policies at that time, the one who is getting this project file and uploading the package must delete this three file, open once and then publish locally first and with the same machine upload to the orchestrator, as per best practices.

We have got this troubleshoot steps from UiPath itself when we were experiencing few occurrences like this in our team long back.

Also, we are assuming the connection is good n this case. let’s see what @vzvenkat has got after trying these many steps.

Always appreciate your curiosity @postwick

1 Like

.settings is recreated with default settings, thus losing any settings changes that were made.

1 Like

Thank you all for you support am good to move on

Thank you Paul!

I was getting crazy because I couldn’t publish a package I had published many times before!
The probrem was too many files in one subfolder.

I did some cleaning and IT WORKED.
It’s incredible the Studio Error Message was not helpful at all! I was lucky reading your post.


1 Like