Proxy setting for package manager

Hello in version 2019.4.2 and also in versions before I am facing a follow problem.
Package manager cannot find any packages. I think this is because of the proxy in my company. Is there any way how to setup the proxy in ui path studio. Tried to search on the internet but did not find anything promising.p1

1 Like

Hi @adam_brauner,
Have you tried to put proxy settings for windows in Internet Option settings?

Hi, yes I have proxy set here but no difference.

The only way I have in my mind in this situation is to download packages manually. Of course I know it is not the point here. Maybe try search through other similar topics to check their solutions.

Search results for 'proxy status:solved' - UiPath Community Forum

Hi @adam_brauner

Could it be due to the firewall of your company as well? You could check with your IT department about the paths of the feeds and whether these are blocked.

Hello,
I resolve it on my own.

Steps:

  1. Download nuget CLI (nuget.exe)

  2. nuget.exe config -set http_proxy=http://my.proxy.address:port
    nuget.exe config -set http_proxy.user=mydomain\myUserName
    nuget.exe config -set http_proxy.password=mySuperSecretPassword

  3. Go to C:\Users[user]\AppData\Roaming\NuGet

  4. Check if the file contains all proxy settings

  5. Restart UiPath.

10 Likes

Hi,

what might also help ist this docs entry:
For 2019 Version:

I will try this myself, since I have a similar issue on my unattended robots.

2 Likes

Hi all!

We have also struggled with this for quite a while. In the package manager we got a 407 Proxy Authentication Required error.

So far we have resolved it by adding the following snippet to the C:\Users\USERNAME\AppData\Roaming\NuGet\NuGet.Config file

<config>
  <add key="http_proxy" value="[PROXY_ADDRESS]:[PROCY_PORT]" />
</config>

The <config> tag is added in between the <configuration> tags.

We are still to find a solution on how to make this a default value :slight_smile: