Project panel does not show folder structure

Hi all,

My project panel doesn’t show the directory structure. It just shows Dependencies.

Can someone can guide me how to show the full directory structure.

Thank you.

1 Like

Hey @HongQuangVN

Is it showing in File Explorer ?

Thanks
#nK

Hello @HongQuangVN ,

Please go to the project folder(in the local) and see whether the .xaml files and other folders are available. If it’s available, please reopen the project (better to reopen the studio also)

Yes. Of course.

File explorer is completely normal.

The problem occurs when I add a new .xaml to the project.

Then I have tried re-starting uipath and opening other projects but the error is still.

I have tried but it still not available

Did you tried to create a new project? If not please try to do that and check whether the issue is happening. If already tried please go to Home->Settings->General->Reset Settings

If it’s some setting issue it will get resolve.

@HongQuangVN May I know did you copy this file from any where else and trying to open ?

@HongQuangVN

Can you please uninstall and Reinstall UiPath and then check once.

Hi Rahul,

I have created new project and it not faced this problem.

However, old projects still have problems. What can I do with old projects to show the full directory structure?

Thank you.

Could you please check whether the project.json file is available in the Project folder(in the local).
Because it determines the structure of your project and if it gets deleted by mistake it can impact the project.

@HongQuangVN Can you try doing this. Delete the project.json file, I mean keep it as a backup some where (desktop), but it should not present in the current folder. Now, re open the Main.xaml and see how it goes

Capture

Hi all,

This problem has been solved.

The reason is when I created a new project. I changed the project path. Everything was fine then. However, the next time I open the project, it will face above problem.

I think this is a bug in this updated version.

I’m having the same problem as you: after updating to version 2022.4 it’s not loading the xaml files and folders, just the dependencies. There was no modification of the file path. This is just happening after the update. I hope they solve it soon because it is impossible to work in Uipath that way. If anyone has a solution they want to share, I’d really appreciate it!