Process is not going into suspend state

Hello, I am working on a DU process with the action center.
the process is not going into a ‘suspended’ state after executing the activity “Create Document Validation Action”.
moreover when reaching to resume activity, it went into infinite wait and it never resumes (as process never went into suspended mode)
The subsequent action is successfully created in the action center.

I am using the enterprise trial on the community version. I have tested the same on 2021.10 version as well however facing the same problem.

Any leads are appreciated.


  1. After create the process would not go to suspended…if you use wait for documnet validation that is when it goes into suspended
  2. If running from studio …we have to manually click on continue after completing the task…only from orchestrator the process that is suspended will start again automatically

Hope this helps


yes it is NOT going in suspend state, I understand from video that it needs to be manually resumed from studio b ut for that process must go to suspended state, how ever it is not going into suspended state(upon executing Wait For Document Validation Action And Resume activity).
I have followed each steps exactly from youtube videos however it is not working.

Can it be a Bug with some particular version?? can you confirm which version it worked(if you tried personally)


Forms version - 23.4.3
System - 23.5
Du - 1.21.1

It is working

And suspended in the sense the bot when run from studio it will be pasued you will see an option continue and it would start again

Just now tested as well


@Anil_G persistence Activities for these forms are working fine for me as well.

as I mentioned in the original question, I am facing this issue only with DU activity.

Action creation Activity:- Create Document Validation Action → working fine creating task in aciton centre.

Wait and Resume activity:- Wait For Document Validation Action And Resume - process not going into suspended mode, it is in executing mode for a long then gets timeout


Can you show the output panel…is a task created?

did you validate?

and if exception can you show the exception details from locals panel exception details please


Hi @RK_S ,

Additionally to what was asked, could you also show us the properties that was configured for the Wait for Document Validation Action and Resume activity ?

Also, maybe a similar issue was already recorded and addressed :

there is known BUG in system.activities pack. I donwgraded to 22.X.X and it is working.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.