Process from Studio to Robot

Hello everyone,

I’m working in an environment where I have 2 systems.

1 Studio on a test/development hyper-v machine
1 Robot on a live/production hyper-v machine

Running version 2018.2.3 on both systems.
No Orchestrator.

I ran into an issue with a process that ended with a Kill process activity and it unfortunately closed all relevant process on all sessions on the system. We found a work around for this in the form of KillProcessByUser from the “Manage packages” in UiPath Studio. So far so good, the new solution is working perfectly on the test/development machine. The real issue came when I wanted to implement the solution to the live/production machine where the Uipath Robot is installed.
I’ve narrowed it down to the fact that the live/production machine does not have the required dependencies or packages for the KillProcessByUser activity, but since there is no studio, then there is no “Manage packages” UI for me to download them and various attempts at copy/paste the packages and dependencies from the test/development machine to the live/production machine has yielded no positive results.

To sum up. How do I move a process with all it’s dependencies and processes from development to live without an Orchestrator.



Go to UiPath orchestrator on your production machine.
Go to packages.
Select Explore dependencies and see if all dependencies are available or not.

If not, Upload package manually. In order to do so, first you to publish your project to a local system and upload this in orcestrator.

No orchestrator is present so neither of those options is a possibility.

Publish code locally in your test environment.
Copy Nupkg to your prod env.

What directory should i copy it to?
I feel like I’ve attempted this, but maybe I’ve put it in the wrong place.


This is a default location :_ %ProgramData%\UiPath\Packages

I think this might have solved my problem.
Currently awaiting the production environment to either fail or succeed.
Thank you for the help

1 Like