Problem with HTTP POST request


#1

Hi there!
I am having a problem when I need to send specific information with HTTP POST request. The goal is to send the information either with Json body field or with parameters but I need to include array values which I have not been able to get working. I have all the required values in my CSV file and I need to use dynamic values with each row activity. I tried using the Json body field but don’t know how to correctly pass the value.

I have made a working workflow with post request and the parameters worked perfectly with dynamic values but this time I have to fill in about 10 attributes and the array part is giving me problems.

How to pass either all of this information in Json body field or how to create a Array parameter?

Here is the Json which I need to send but with dynamic values:

{
“name”: “string”,
“description”: “string”,
“synonyms”: “string”,
“thingNamingFormula”: “string”,
“isUnique”: true,
“classificationItemId”: “string”,
“attributes”: [
{
“id”: “string”,
“attributeGroupId”: “string”
}
]
}


#2

Hello @magsluib,

Take a look at this:


#3

Hello
I checked this issue but I wasn’t able to get my variable working.
I have my variable stored in the “Body” field but something is wrong in my variable. The problem is how do I pass dynamic values to “Body” like row(“name”).ToString, it just outputs them as row(“name”).ToString was just one string and not dynamic value.
Have any suggestions? Or solution to passing array values in the parameters. (Dynamic parameter values work except the array one)
Here is my variables value:
"{ ““name””: row("“name”").ToString, ““description””: row("“description”").ToString, ““synonyms””: ArchetypeSynonyms, ““thingNamingFormula””: ““string””, ““classificationItemId””: ““string””, ““attributes””: [ { ““id””: ““string””, ““attributeGroupId””: ““string”” } ] }"
Most values are still missing but I think this will give a better picture of my issue. What is the correct way to write this and how to pass the array values? (Array values are also dynamic)


#4

I have the same issue! Is it possible? It doesn’t seem, because parameters must be of string type. If I deserialize an array or an object, API obviously receives a string.