Problem with click activity

Hello all,

I have a problem with a click activity that I can’t get solved.

On a webapage is a button whose " "
ID changes.
For this I have starred the “,” but as soon as I validate the selector, I get the message that it is not found.

Even with click Image and a Find Children loop, the bot does not get the button pressed.

IFRAME
IFRAME2
IFRAME3

@NHoe

Instead of parentid, can you search another tag which is stable?

Thanks

Unfortunately no, that’s all the page offers

@NHoe

Can you click on UiExplorer and check if you have any other tags or share that screenshot

Thanks


here the screenshot

@NHoe

Great!!
So search here a stable tag where you can build your dynamic selector
May be idx will also work by using a counter value and incrementing that

Hope this may help you

Thanks

Hi @NHoe ,

Have you tried inspecting this click with Active Accessibility mode.
May be you will get more stable selectors.

Thank you, it works.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.