Problem with cert in Windows Orchestrator installation

Could you clarify what’s not working?

We solve this problem. Our system engineer converted certificate as for old systems(TMG and SQL) and it changed how properties are stored.

1 Like

Hi Dustin,

We tried to install orchestrator from both the Platform installer (20.4.3) and with the orchestrator.msi (20.4.3), but on both got the same error as mentioned by @rekses.

Our solution was:
Installing using the orchestrator.msi (20.4.3) using a self signed certificate and then upgrading the certificate using the organization trusted certificate.

Before upgrading the certificate, we changed the following properties in our organization trusted certificate:

  • Common Name : with 2 specific DNS Alias as per our requirement
  • Subject Alternative Name: As per our requirement
  • Key Usage Features: Digitial Signature, Key encipherment
  • No changes to the private key

Our Orchestrator installation is now complete :checkered_flag:

Feedback to UiPath:
This experience did leave a sour taste and we hope, in the future, it will be a much smoother experience for onprem customers. The documentation needs to be updated with possible failures during installation of onprem orchestrator. For example, a section on minimum requirements (properties) of the trusted certificate required by UiPath and a possible troubleshooting step as mentioned by @vlad_rpa.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.