Problem in Running process from orchestrator to Production machine (Community edition 2019.10.4)

Hello,

I am having trouble running processes from orchestrator to Prod machine. It is working fine when I am connected to the machine ,the process will not work if I am disconnected. The same problem exist for all the processes where we have clicks and also the Workflows which take screenshots.
There is no problem in running background processes.

I tried changing resolution in UiPath settings file as well as in orchestrator Also tried simulate click. Simulate click seems to be working but for my process I can’t use simulate click every where.

Can you help me with this issue?

1 Like

Hi @neethulg,
It’s all dependent of what Robot license do you use. If it’s Community then it will be not possible as community robot have service related to user thread what means that it will be unable to catch selectors when you are disconnected from machine.

You can check more information in recent topic about same issue here:

2 Likes

Hi @neethulg

Try this, create a bat file with the following commands;

echo off

tscon %sessionname% /dest:console

Place this on the desktop, and whenever you want to disconnect, simply run as administrator the bat file. This will end your session without locking the workstation, so this could potentially fix the error, the other thing you need to do is to update the Sleep time settings so it doesn’t go to sleep after few minutes

1 Like

@neethulg try installing just robot from .msi instead .exe package

1 Like

Hello Pablo,

@Pablo_Sanchez I installed MSI packge. I was publishing processes from the same machine. My process was just to open browser and take screenshot for that I have to enable chrome extension. but I don’t have a studio now.

How did you add the license for uipath studio in unattended machine after running UiPath MSI?

1 Like

@pablo…I was able to install chrome extension via CMD.

1 Like

Hi @neethulg

You should have your license in the orchestrator platform (if you are using community edition). There you should have created your unattended robot, which has its own machine-key.

Then, in the unattended machine you have to connect the ui robot with the machine on the Orchestrator. After this you will be available to launch processes in the unattended machine. You don’t need Studio.

Also, if you just need the extension, you can install it through Chrome itself.

KR,
Pablo

1 Like

@neethulg try to publish a simple process like that “Take&Save Screenshot” from a different machine.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.