Problem in dynamic selector

I’m using “Get Text” activity and store the result in “someVar” which is of string type and trying to display this value in “Message Box”. The selector which I’m using in “Get Text” activity looks like this:

When I run the process it will give the desired output in Message Box i.e. it will give the value of item which is present in 3rd column at 2nd Index. But, I want to display the value of all the items present in 3rd column. For that I’m using Dynamic selector as shown below:

Here I just replace the idx value from 2 to “index” .
When I try to re-run the process, it will throw following error:

Here is the screenshot of UI:

Please help me and let me know why I’m facing this issue.
Thanks in advance

Hello @Suyash0890,
Try assigning the full selector to a variable and use the variable as in your “Get Text” activity.

I believe, when you use a variable in the selector directly in “get text” activity, UiPath sends the variable as string instead of sending the value of the variable.

Replace & quot; with a " and do this correction in expression Box not in Explorer selector expression dialog. In case the expression box will not open type into a third plus. This will let fail Validation and the expression Box opens

UiPath will automatically convert " to “&quot”. I have placed the whole expression in the “Expression Editor”, but still it is not working fine. Since, I’m new to UiPath, I’m not getting what you are trying to refer through “Expression Box”

Thank you so much for your valuable suggestion, I’ve tried to achieve the same using a variable and put the whole expression in that variable, but issue still persist. please let me know some other way to handle this.

UiPath is converting " into & quot ; automaticly when it is entered within UiExplorer editior.
It can be corrected when using in the expression box from the selector within the activities properties

Click on the 2 dots Button (Screenshot 1 Yellow Line)
Copy entire Selector into the Expression Editor

Maybe your Index Variable is not of type String, So use a toString

If you face again any issues please post a screenshot. We can guide you then quickly.

Thank you so much for the quick response.
I’ve already followed the same steps which you have mentioned in the above post i.e. copy the whole expression from “UiExplorer” window and pasted it in the “Expression Editor”. Still, it will automatically convert the ‘’ into '&quot". Even, same thing is happening when I’m using “index.toString”.

@Suyash0890 please post some screenshots