Possible solution in case of problems with Excel and UiPath

excel
activities

#1

I share my problem and in turn the solution to an error in UiPath when you try to use the activity “Excel application scope” for a process in excel.

The error:
“Message: Error opening workbook Make sure Excel is installed.”

The problem:
UiPath assumes that you do not have Excel installed on your computer, when in reality you may have excel installed correctly.

The detail is when the UiPath wanted to call Excel through the COM automation (which uses an address where the excel is installed) is possibly calling an address that does not exist. (Image 1).

The solution:
The solution is to change the path that the record has to the one with the Excel installed

This is done through the register editor (regedit) once you look for the path “HKEY_CLASSES_ROOT \ TypeLib” after that, the excel record, which in my case is {00020813-0000-0000-C000-000000000046}
Once inside, open different capetas.

For example, in the path “Computer \ HKEY_CLASSES_ROOT \ TypeLib \ {00020813-0000-0000-C000-000000000046} \ 1.7 \ 0 \ win32” the record that had the path saved was correct.

However in the path “Computer \ HKEY_CLASSES_ROOT \ TypeLib \ {00020813-0000-0000-C000-000000000046} \ 1.9 \ 0 \ Win64” the record that had the path saved was incorrect, because it had "C: \ Program Files \ Microsoft Office \ Root \ Office16 \ EXCEL.EXE "An Excel that possibly existed previously on the computer, was deleted but the record was never deleted.

After that change the value of the route to the correct and ready, problem solved.

See you later!


#2

In my case path saved is correct but Uipath is looking for a registry that doesn’t exists.