Pdf reading using Ocr Showing Error . RemoteException Wrapping

RemoteException wrapping System.Exception: Error performing OCR: TessErrorLoadEngine —> RemoteException wrapping System.ServiceModel.FaultException: TessErrorLoadEngine
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc) at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object outs, IAsyncResult result) at System.ServiceModel.Channels.ServiceChannelProxy.TaskCreator.<>c__DisplayClass7_01.<CreateGenericTask>b__0(IAsyncResult asyncResult) at System.Threading.Tasks.TaskFactory1.FromAsyncCoreLogic(IAsyncResult iar, Func2 endFunction, Action1 endAction, Task`1 promise, Boolean requiresSynchronization)— End of stack trace from previous location where exception was thrown — at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at UiPath.Vision.VisionClient.d__5.MoveNext()
— End of inner exception stack trace —
at UiPath.Shared.Activities.AsyncTaskNativeImplementation.BookmarkResumptionCallback(NativeActivityContext context, Object value) at UiPath.Shared.Activities.AsyncTaskNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value) at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value) at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)![re1|690x163]…

2nd error
“Name”: “Read PDF With OCR”, “Id”: “1.7”, “InstanceId”: “4”, “TypeName”:“UiPath.PDF.Activities.ReadPDFWithOCR”
(upload://nYr0OEAfJh5vhj8r6KqehfZjCgX.png) re2


What happens if you change the Tesseract OCR to the Microsoft one?

Hi @Muhammad_Jahangir ,

Please try ‘Microsoft OCR’ and use ‘Scan’ in the field of 'Profile’ drop down.
Hope it will work.

Thanks & Regards,

same error showing

brother i apply the method you ask me but showing error

I apply it and it will showing error.

Brother i use this but can’t working. same error as before
i also change the file. but still not working

Don’t know what to say man it looks like it’s properly configured. What version of PDF activities/ ocr / studio are you using?

pdf version is 3.0.0 and uipath version is
2019.8.0 - 8/29/2019
Community Edition
EXE Installer

Update Channel: Stable

Microsoft Windows 7 Ultimate 64-bit
.NET Framework Version 4.6.2

And for the Microsoft OCR you get the exact same error? Try changing the Profile property to “Legacy” see if that changes something maybe.

error again. can i send you a file?

Sure go ahead.

okMain.xaml (7.5 KB) Text and Image PDF.pdf (131.1 KB)

Just tried it, it works fine for me… this should be an environment related issue. I am not sure how the ocr engines are working behind the scenes but I can assume there is a connection that is blocked on your computer? is it a work computer that you are using/work internet connection?

Yes internet is working

What kind of issue . Please explain . i can’t understand

Can’t tell you but something might block the connection to the ocr engines.

Thanks i’ll try on other Laptop

i have same problem ocr not work .