Outlook New Email Trigger

I published my simple process to a specified folder (let’s call it Email Trigger Folder) and then using integration service, i added outlook connection and added trigger which should trigger the process after i recieve new email with subject Approved". In the folder level, i was able to see the event trigger and also i did configure in Package requirements. But no matter what I did the process is not executed. there is some problem with running in unattended mode. But i cannot figure out why ?

@bhaskar

Can you show the trigger how you configured and all…

Some screenshots will help

Cheers

sure buddy,





so, whenever i send email the jobs are created immediately and i can also see that in trigger logs, but i the jobs are pending but not executed. i even tried executing by starting the process manually, but the process is not executed.

@bhaskar

Okay…

  1. Go to tenant → maachines and check if the machine is allocated a license and check if it is available
  2. Go to tenant → manage access and check if user is given necesaary permissions
  3. Connect the machine usi by machine key …also make sure you install robot in service mode

Cheers

can you eloborate on the last point please. i did add the machine key and everything in ui path assistant. i m not sure about installing robot in service mode


My Assistant also connected with oulook

@bhaskar

Assistant is fine…but is it service mode…means while installing you should select service mode…you would have user and service…attended will work for usermode and unattended will work with service mode…and to trigger automationfrom orchestrator service mode installation is needed

Cheers

I might have done that mistake while installing. i guess i should re install now ? and this time i should do it in service mode ? right ?

@bhaskar

Exactly yes

Not one thing if you are on community version then you might not be able to install in service mode…

In that case you can keep your laptop open and available…and in machine in orchestrator provide the credentials and then run…it should work…but keep laptop logged in else it wont start.

Cheers

im in trail enterprise version right now. however my friend is in community version and when she started manually from orchestrator the process worked. should i change it community as well ?

@bhaskar

Enterprise trail should work…you can install in service mode

Do you see machine as acailable in orchestrator?

Did you give the credentials there?

Is a license assigned?

Cheers

i see the machine as availabel and connected



HOw can i do that ? how i can install in service mode ? i mean do i have to uninstall studio , assistant and everything and reinstall ?

@bhaskar

Yes you must reinstall in srvice mode

also did you give the lciense and the username and password of machine?

is the robot created and attached to folder?

cheers

yes i did give user name and machine password while creating the unattended setup and yes the robot account and machine are attached to the folder

I installed Unattended mode with studio.
this time the job is reaching out to the machine and giving username or passowrd wrong error. i changed my password in users and accounts in windows and updated my robot account.still im getting the error. i thought it must be the PIN so i gave the PIN but again it throws me error.

@bhaskar

For username open cmd and type whoami…and the response is username…

And for laptop if you give pin it would not work…change authentication to password and provide the password

Cheers

Bro. Finally it worked bro. Thanks a lot. If you wouldn’t have told me to jnstall in service mode, i would have never ran an unattended robot. Thanks a lot man.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.