Orchestrator successfully runs my robots nut there are no log files

I am confused and I wonder if someone can explain what I am doing wrong. I ran and tested my simple robot in UI Path and the Output window showed all my log messages. I published the robot successfully, then ran it. It said it ran successfully, even created a txt file but there are no Log messages to view.

This is the Output results in UI Path Studio

This is the Detail report

I would appreciate some insight as to what I overlooked.

MaryB

1 Like

Hi @MaryB2019

Its a good topic… So Once you are in the Jobs page, for every job listed there, if you hold the mouse on the job, you have two options.

  1. View the job

  2. More info → View logs

  3. View the job
    This is what is shown in your screenshot. This actually shows the final status of the job. This mentions whether the job run was successful or not along with some additional information such as what is shown in the screenshot of yours.

  4. More info → View logs
    This is where you see the actual logs of the execution. However, the logs that show here depends on the Log Level of the robot. This log level is set in the robot page under robot settings.


    The logs that are shown under logs depend on the level you have selected here.

So what information is captured in every log level? That is well explained in the below article of Uipath
https://orchestrator.uipath.com/docs/logging-levels

As an example, let’s say you have selected error level for the log level. Now you run the application and it completes successfully. Now if you check your logs, you will not see anything. Why? because it was asked to capture error logs, not normal execution logs. Since the process completed successfully, there are no errors to show.

That’s the basic idea here :slight_smile:

Hope it helps!!

Let know if this works for you or if you need any more explanation on this… Would be glad to help.

if it helps, please also make sure to mark my answer as the solution too… :slight_smile:

1 Like

@MaryB2019
Buddy
In community edition sometimes this happen with few settings been disabled…no worries buddy…if they are enabled you are done…

Moreover job details willgive you only the robot name, machine name, when it started and when it ended, what input you gave as parameter and what parameter you assigned as output or to be added as a log field,

To see the log files click the three dots vertically, to check the logs of the process, or to be very simple to see the messages that you see in output panel of studio(the image you attached from studio)…additionally you can see some trace - about the activities entry, some info - whether the activity completed or not, some warning and erros…

Still if you are not able to see the log
Check whether you have the access to read the logfiles and this can be enabled by clicking your username at right top corner
then check with roles tab for your robot

HOpe this would help you

Cheers

1 Like

Thank you for trying to help but I made the change as seen below and still no log messages when I click on View Logs or when I attempt to download. The file is empty. And I am running the Community Edition.

MaryB

@MaryB2019
Buddy Did you run once after enabling this…

Cheers

Thank you for trying to help I did find the settings and changed it as you can see in the snap shot, but when I View Logs, there is nothing and even when I attempted to download the log they were empty.

I even tried changing the Robot roles as someone else suggested but still no luck.

MaryB

@MaryB2019
Buddy may be this can help yo

and this as well buddy @MaryB2019

Cheers

You are trying so hard to help and I’m afraid I am too new at this that I am taking up your time. Orchestrator is not installed on my PC. I am taking a course which allowed me to access the platform.uipath.com to create an Orchestrator account. So, I don’t have access to the web.config.

Thank you anyway for all the time and effort. I have written to the course’s author so maybe he can explain how to get around this.

Mary B

1 Like

amazing ,keep going buddy…!