Orchestrator Job fails with Could not load file or assembly 'UiPath.UIAutomationNext

the automation runs well in Studio - when started from the Orchestrator or the Assistant - it errors out with the Could Not Load File or Assembly… I did follow some of the suggestions on the forum - deleting .Nuget packages - no change in behavior even after a republish

I do see the UiPath.AutomationNext.Activities in the Imports area - not sure if I can delete.

Lost here…

This is from the orchestrator log file:

  • Info: Could not load file or assembly ‘UiPath.UIAutomationNext, Version=, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified.

System.IO.FileNotFoundException: Could not load file or assembly ‘UiPath.UIAutomationNext, Version=, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified. at XXXXXXXXXXX.GetImplementation()
at System.Activities.Activity.OnInternalCacheMetadata(Boolean createEmptyBindings)
at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors) at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack1& activitiesRemaining, ActivityCallStack parentChain, IList1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback) at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)
at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList`1& validationErrors)
at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.WorkflowApplication.EnsureInitialized()
at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push)
at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout)
at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state)
at UiPath.Executor.RobotRunner.RunWorkflow()


The studio machine try copying the required package folder to the target machines .nuget folder and check


Hi - it’s the same VM that executes (Studio is on this machine) - Orchestrator executes against this VM.


Please try deleting thw project.json and reload the project and then upload the package again

Ideally on smae machine you shpuld not face any issue…

Please check the feed as well


Hi tried deleting project.json - and reload and republish - same issue with orchestrator assembly error.

Still not working - the only thing I have not tried is a complete new install/rebuild but that seems drastic in this day and age.

This can be closed - the message was resolved after I resolved this issue first.