Getting error Could not load file or assembly 'UiPath.System.Activities'

We’re using an on-premise orchestrator version 21.10.4 with studio/robot version 21.10.6. We have a project that was on the Windows - Legacy framework and functioned correctly on that framework.

We’ve changed that project now to use the Windows framework to compile the process for performance as well as to get us ready to migrate to a new platform version.

Dependencies are set to the UiPath.Mail.Activities version 1.12.3, UiPath.SystemActivities version 21.10.5, and UiPath.UiAutomationActivities version 21.10.5.

When we publish the project to the orchestrator, there are no errors.

When we launch the job to run as an unattended foreground process on a robot machine, after some time, we see this error

Could not load file or assembly ‘UiPath.System.Activities, Version=, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified.

This is happening at the Invoke Workflow call seen here.

Note that there are other Invoke Workflow calls that are executed prior to this one within the same workflow file and those are not generating an error.

We’ve tried clearing the cache for the user and the user profile and for studio, creating a new copy of the project and importing the workflows, and we’ve tried going down to 21.10.4 version of the UiPath.System.Activities package, all with the same results.

Anything that you could give us to help out would be great.

A couple of questions that we have that are on our lines to try:

  1. Can we run a newer version of Studio/Robot without having to upgrade our Orchestrator version?
  2. Are there newer versions of the UiPath.System.Activities package that are compatibile with our version of studio/robot that we can access somewhere?

Thanks in advance

We’ve managed to cobble together a solution on our end.

Basically, the workflow XAML file being invoked seems to have some sort of internal structure errors that are not visible within Studio. What we ended up doing is creating a new XAML and copy/pasting the contents of the old XAML into the new one. This resolved the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.