Orchestrator Installation as Azure App Service


#1

Hi,

I have deployed the Orchestrator as an Azure App Service following the ‘One Node’ installation in https://orchestrator.uipath.com/docs/the-azure-app-service-installation-script.

However, it looks like I cannot access the website and I’m always getting runtime error.
Azure Diagnostics says: Your app is healthy, Platform is healthy

Anybody here who had deployed Orchestrator successfully as an Azure App Service?

Do you have any additional steps apart than those steps 1-8 in https://orchestrator.uipath.com/docs/the-azure-app-service-installation-script?

Have you uploaded any SSL Certificates to Azure?

Looking forward for your response. TIA


#2

Please disregard, I got this fixed. Thanks


#3

Can you please explain what next steps you did? Im facing the same problem.


#4

in my case, it was because I cannot connect to SQL DB, I just updated the connection string on my web.config file.


#5

Note that the ID that is used to create the DB during an installation or an upgrade will need to have access to the master database.


#6

Hello all,

I am trying to run Orchestrator in Azure but I am getting a runtime error.
I have followed the 8 steps tutorial for Single Node installation, but still it gives me two types of errors when running:
Error 1:


Second run:

Here is the details:
PowerShell installation ok

Connection String config:
Server=tcp:uipathsql.database.windows.net,1433;Initial Catalog=Orchestrator;Persist Security Info=False;User ID=toechsle@uipathsql.database.windows.net;Password=xxxxxxx; MultipleActiveResultSets=False;Encrypt=True; Connection Timeout=30;TrustServerCertificate=True;

Application Settings:
{
“LoadBalancer.UseRedis”: “false”,
“LoadBalancer.Redis.Port”: “6379”,
“LoadBalancer.Enabled”: “false”,
“NuGet.Packages.ApiKey”: “e99ec691-cd1e-4ac0-972c-e8baaccafa71”,
“NuGet.Packages.Path”: “~/NuGetPackages”,
“OrganizationUnit.Enabled”: “false”,
“LoadBalancer.Redis.Server”: “”,
“NuGet.Activities.ApiKey”: “e99ec691-cd1e-4ac0-972c-e8baaccafa71”,
“AcceptedRootUrls”: “*”,
“NuGet.Activities.Path”: “~/NuGetPackages/Activities”,
“LoadBalancer.Redis.Password”: “”,
“LoadBalancer.UseSqlServer”: “false”,
“Tenant.Registration.Enabled”: “false”
}

I have also changed the connection string in Web.config file:

What am I doing wrong?


#7

Hi,

Were you able to fix the issue. We are also facing the same issue after deployment of Orchestrator on Azure. Any response is highly appreciated!

Regards,
Ramreddy


#8